# Contents

1 Introduction 5
   Document Structure 5

2 crowd:it and CAD software 7
   Creating Simulation Objects 7
   Utilizing CAD for crowd:it 7
      Recognised Elements 7
      Closed and Open Elements 8
      Layers 8
      Check Units and Scaling 8
   Vectorworks 8
      Creating Simulation Objects using a database 9
      Creating a floor plan from a 3D Model in Vectorworks 2019 10

3 crowd:it Introduction 11
   Quick Intro 11
   User Interface 12
      Menu 12
      Play Bar 13
      Floor plan view 13
      Simulation Information 13
   License 13
   Updates and Assistance 13
      Documentation 13
      Updates 13
      Help 14
      About 14
      Escape (ESC-Key) 14

4 Step-by-step Modelling Process 15
   Step One: Import Your Floor 15
      Importing Floors 15
      Floor properties 16
      Move floors 17
      Delete current floor 17
      Directly editing via floor popup menu 17
   Step Two: Assign Simulation Objects 17
      Origin 18
## CONTENTS

- Destination ................................................. 19
- Scaled Area .................................................. 20
- Directed Scaled Area ....................................... 20
- Waiting Zone ............................................... 21
- Queuing Area ............................................... 22
- Stair ......................................................... 23
- Escalator ..................................................... 25
- Elevator ...................................................... 25
- Portal (Legacy) .............................................. 26

**Step Three: Create Simulation Parameters** .......................... 27
- Paths in the GUI ............................................. 27
- Editing via the Menu ....................................... 29
- Visualize Hierarchy ....................................... 34

**Step Four: Settings** .......................................... 35
- Quick Select .................................................. 35
- Settings ......................................................... 37

**Step Five: Simulate** .......................................... 38
- Run simulation ............................................... 38
- Statistic runs ............................................... 39
- Continue editing ............................................. 40

**Step Six: Visualise** ........................................... 40
- Section One .................................................... 40
- Section Two .................................................... 41
- Section Three ............................................... 42
- Section Four ................................................... 43

**Step Seven: Analyse** .......................................... 45
- Agents ......................................................... 45
- Evaluation objects ......................................... 46
- Charts ......................................................... 48
- Summary tables ............................................. 53
- Heatmap... ...................................................... 53
- Reporting ....................................................... 56

**Step Eight: Export** ........................................... 58
- Take screenshot... ............................................ 58
- Batch take screenshots... ................................. 58
- Export video to file... ...................................... 58

5 Project Work 61
- Step-by-step example: "Grüne Wiese" .......................... 61
- AutoCAD ......................................................... 61
- crowd:it ......................................................... 61

6 The crowd:it Toolbar for AutoCAD (Legacy) 63
- Installation of the Plug-in .................................. 63
- Components of the Plug-in .................................. 64
Chapter 1

Introduction

Congratulations! You have selected one of the most advanced pedestrian simulators on the market. Founded in 2014, following studies at the Technical University of Munich (TUM), accu:rate GmbH provides the latest research in crowd simulation to practitioners including engineering firms, event organizers, crowd managers and fire fighters. Regardless of the density of the scenario; be it low numbers of people in an office, or enormous industrial complexes, museums and outdoor events, the state-of-the-art mathematical models at the core of our software deliver valid results you can trust. With crowd:it’s clean and self-explanatory user interface, you can focus on the project and not the software.

The following documentation serves as a reference. Online video tutorials and in-person training sessions are also available.

Document Structure

The order of this documentation is based on the workflow of a project. Typically, this begins with simplifying engineering plans, before marking specific objects and surfaces as Simulation Objects (e.g. entrances). For this, commercially available 2D CAD software packages are suitable, e.g. Autodesk\textsuperscript{TM} AutoCAD. Plans created in the CAD software can be directly imported into crowd:it. Next, pedestrian (hence-forth named agent) movements are modelled and, in a further step, their behaviour analysed. Finally, the results are produced and exported.

We wish you every success with your crowd:it project!
Chapter 2

*crowd:it* and CAD software

In order to simulate agents in an environment, you first require a plan of that environment. Plans should be generated in CAD software and then imported into *crowd:it*. Elements that have a special function in the simulation must be modelled as generic “Simulation Objects” in your CAD plan and will later be assigned their function in *crowd:it* (see Step Two: Assign Simulation Objects).

With *crowd:it*’s .dxf importer, you can import any CAD file in *crowd:it*. Compatible, tested CAD software can be found here: https://www.accurate.de/en/compatible-cad-packages/.

This chapter explains how to create Simulation Objects.

**Note:** Simplicity in your plan is key. Simplification saves simulation time – every line of your plan affects the computation time – and provides clarity. Especially for complex simulations with a high number of people, any simplification is welcome.

Creating Simulation Objects

Simulation Objects are undefined elements of a simulation that will have a particular function. You can create a Simulation Object via one of two methods:

- The first is to include the word "crowdit" somewhere in a layer’s name and place relevant Simulation Objects on this layer. E.g. you could have a layer named *crowdit-stairs*, in which you model all the stairs in your plan.
- Alternatively, set a layer or object’s colour to: RGB-232/78/15 (or #e84e0f in hexadecimal).

Utilizing CAD for *crowd:it*

**Recognised Elements**

*crowd:it* recognises the following CAD elements: Lines, Polylines, Circles, Arcs, Ellipses, Solids, Splines, LWPolylines and Mlines. Elements inside
Blocks will be imported accordingly.

Other elements, such as Hatch, Text, Image etc. will be ignored.

Closed and Open Elements

Closed elements are treated as inaccessible obstacles for agents. Agents cannot escape from such obstacles, nor can they enter them. Conversely, open elements are accessible objects that agents can, given enough room, leave and enter. In particular, it is important that Origin and Destination elements are open, otherwise agents may become trapped.

Layers

You will often use layers to sort building elements and Simulation Objects. As such, name each layer suitably. For instance, you may have a layer for walls, a layer for entrances and a layer for showers and toilets.

Note: Frozen layers will not be imported in crowd:it. Therefore, frozen layers can be used for guidelines. By managing your layers, it is possible for the same wall (or object) to be obstructive in one scenario and not in another.

For simulations of several floors it is still a good idea to create more than one layer per floor. Groups of layers can be frozen meaning it possible to hide and show floors relatively easy. We recommend you store floor files in an orderly manner and create one folder per floor, since each floor must be stored in a separate floor file.

Check Units and Scaling

In order for the exported geometry to be consistent, and consequently the simulation to be realistic, plans must be to scale. Check the units.

Vectorworks

Export your drawing directly to a crowd:it .floor file using our Vectorworks Export Plugin. We offer a video tutorial explaining the installation of the plug-in as well as a short demo video showing Vectorworks 2019 and crowd:it in action. Be advised the Vectorworks DXF export will break re-importing changed floors - use our plug-in instead.
Creating a simulation with Vectorworks is very similar to using other CAD software. Create Simulation Objects by setting your layer’s colour, including crowd-it in the name of a class, or, especially for Vectorworks, using a Vectorworks database.

**Creating Simulation Objects using a database**

By using databases to create Simulation Objects, you need not reorganize your drawing, as you would for class naming and colour setting.

**Using the Plug-In**

The plug-in installer provides a menu item named *Tag as crowd-it simulation object*. Select the geometry objects you wish to become Simulation Objects in crowd-it and click on this menu item. It will carry out all necessary database tasks automatically.

**Manually**

Create a database named dbase_crowdit with a single Boolean named crowdit-obj, whose default is true. Any geometry added to this database will become a Simulation Object in crowd-it.
Creating a floor plan from a 3D Model in Vectorworks 2019

A 3D model is an excellent basis for a simulation in crowd:it. To work with a 3D model, use horizontal cuts to separate floors. To do this:

1. Use Clip Cube (DE: Schnittbox) to create a ‘horizontal section cut’ through your model, including all geometry relevant to your floor.
2. Right-click on your horizontal cut and select Create section viewport... (DE: Schnitt anlegen...). In Vectorworks 2019, the context menu has this option twice. Select the latter – the final menu option. **Note:** Set the scale as 1:1.
3. In your newly created cut, select all objects and from Modify (DE: Ändern) select Convert > Convert to Group.... (DE: Symbol/Objekt wird Gruppe...) to turn all intelligent objects into plain geometry.
4. Copy all these objects into a new document. This pastes all objects to a construction layer - layout layers are not exported into the crowd:it floor file.
5. Continue your work as normal in the new plan: Create a crowd:it class, add Simulation Objects, etc.
Chapter 3

crowd:it Introduction

Quick Intro

Our Quick Intro, accessed via the Welcome screen and Help menu, introduces you to the most basic crowd:it functions:

- Creating an Origin
- Creating a Destination
- Creating a Path
- Running a Simulation
User Interface

The user interface is divided into several areas, which we discuss below.

Menu

At the top of your screen you will find the Menu Bar. Here several menu items can be selected. The menu is modelled on project workflow: work from left to right.

At the far left is File. Here you can open and save simulations (and create Screenshots and Videos).

Next to File is Edit. All parameters for the simulation are defined here and floors can be managed.

Under the heading Simulation individual or statistical simulation runs are managed.

Visualize allows you to visually analyse a simulation. Some visualisations are only relevant after your simulation has run, so it will be available only with simulation results.

The penultimate menu, Analyze is also only available after a simulation run. Here you will find a variety of tools to quantitatively evaluate your simulations (e.g. identifying individual agents and their routes, or providing a Heatmap of density throughout the simulation).
Play Bar

The **Play Bar** is only available if a simulation has already run. With it, a simulation can be played, paused and rewound. What’s more, your simulation can be restarted and in “paused” mode, micro time-steps considered. Along the bar, you can identify exactly where you are in the simulation and move forward or backward as you wish.

Floor plan view

The **floor plan view** displays the simulation. Here, you can view and edit your simulation directly in the imported floor plan.

Move within the map by pressing down on the scroll wheel and dragging, or use your keyboard’s arrow keys. Additionally, you can center the map under **Visualize > Center floor**; shortcut **Ctrl+J**.

Simulation Information

On the side of your display, **Simulation Information** provides you with quantitative simulation data. Naturally, this is only available after a simulation has run.

License

With **File > License Details** you are able to view and edit your current license details.

Updates and Assistance

Documentation

With **Help > Open documentation** you are able to view the documentation corresponding to your **crowd:it** version.

Updates

Each time you open **crowd:it**, our software will search online for a newer version. If a newer version is available, updates will download in the background automatically. As soon as the download is complete, you will be notified at the top right of your screen. By selecting this notification, you can close your current version of **crowd:it** and open the same project again in the updated version. Alternatively, the newer version of **crowd:it** will be used automatically the next time you open the software.
Version-Conversion

In the long term, we may update the file format required to simulate with crowd:it. If this does occur in the middle of your project, your files will no longer be compatible. Our software will however convert your files automatically the next time you open them. The old simulation files will not be overwritten and the converted file will be opened in crowd:it. You can overwrite the old files if you wish, or store any new simulations in another location using Save As.

Help

With Help > Get help from accu:rate you can create a Support Request, which is sent directly to accu:rate. Use Support Requests to communicate problems you encounter, or to suggest software changes. Simply fill in the form. For privacy, the field Project Details is by default unchecked. In most cases it will be difficult to assist you without more details so be sure to check this box where appropriate.

About

With Help > About... you can view the version of your crowd:it installation including the individual version number of the graphical user interface (Gui) and the simulation calculation unit (Kernel). Here you also have access to the link to the current changelog.

Escape (ESC-Key)

Press Esc to abort an action.

Abort from:

- the creation of paths
- drawing or moving evaluation lines or polygons
- following an agent
- editing any settings (Cancel acts similarly)
Chapter 4

Step-by-step Modelling Process

Our modelling process is as follows:

Step One: Import Your Floor

Importing Floors

After creating a new simulation file, floors are required, upon which agents can move.

In order to import your floor(s), head to the Menu Bar and select Edit > Add floor....
With **Add floor**... .dxf files can be selected. If a floor already exists, **Add floor**... will ask whether you would like to **replace** or **insert** a different floor, whose name you can edit later.

In order to change individual Simulation Objects, each object must have a unique name. If not, the user will be notified and the import will be blocked.

For **replace**, there are three reasons adding a new floor may be blocked:

- Duplicate: One of your current floors (one you do not wish to replace) has the same ID as the floor you are trying to import.
- Incompatible changes to the geometry: A former staircase is now a triangle, and a former escalator is now a circle etc.
- Simulation Objects with a feature in the current floor are not in the floor you wish to add.

For **insert**, there is one reason adding a new floor may be blocked:

- Duplicate: One of your current floors (one you do not wish to replace) has the same ID as the floor you are trying to import.

If a floor is unsuitable for replacement or insertion, the OK button is deactivated, a (!) is displayed and more detailed information is available by hovering over the highlighted floor.

**Floor properties**

With the menu option **Edit > Properties of current floor**... the properties of the current open floor can be viewed and edit.

**Name** Identifier for this floor.
**Height** The Height variable defines the height of a floor in meters.

**Elevation** Elevation specifies the position of one floor relative to all the others. By default, this is set to 0.

**Cell Dist** Here the discretization of the floor can be set in metres.

With the menu option **Rename current floor...** the current (open) floor can be renamed. Duplicate names are not permitted.

**Move floors...**

Here you can change the order of the floors. E.g. the cellar is actually above the basement, not the other way round.

**Delete current floor**

With **Delete current floor** the current (open) floor is deleted. If you choose to delete a floor containing a Simulation Object, a warning will display.

**Directly editing via floor popup menu**

To edit the properties of a floor, delete or replace it or insert another floor after this floor, right-click on the floor’s tab (just above the Main Visualization Window) to open the following:

![Floor popup menu](image)

**Step Two: Assign Simulation Objects**

After importing a floor file all Simulation Objects will be initially orange (see below).

Use a right mouse-click on each object to specify the function of an Object, e.g. Origin, Destination, etc. If several Simulation Objects lie on top of one another, a menu will ask which Object you wish to work with. To manage multiple objects at once, select them by dragging a rectangle over the Objects you wish to select. When dragging from left to right, an Object is only selected if it lies completely inside the selection rectangle; when dragging from right to left it is sufficient if only a part of the object intersects with the selection rectangle. It is also possible to individually select additional objects by clicking the left mouse button while holding down Control.
18

CHAPTER 4. STEP-BY-STEP MODELLING PROCESS

The following Simulation Objects can be assigned:

- **Origin**: Sources of agents who are generated either immediately or gradually throughout the simulation.
- **Destination**: Targets that 'pick up' agents. They can also be considered sinks that remove agents from the simulation.
- **Scaled Area**: Areas that decelerate or accelerate agents.
- **Directed Scaled Area**: As with scaled area but with an added directional variable. Accelerate and decelerate agents based on their direction.
- **Waiting Zone**: Areas in which agents wait.
- **Stair**: Stairs can connect two floors.
- **Escalator**: Escalators can connect two floors.
- **Elevator**: Elevators can connect multiple floors.

Simulation Objects that can be created from lines:

- **Queuing Area**: Elements representing queues or queuing areas.
- **Portal (Legacy)**: 'Teleporters' that connect two floors.

After selecting one of the above, a settings dialogue will open. Generally speaking, the dialogue contains the name of the Simulation Object and settings corresponding to its type. If a setting is invalid, a red exclamation mark (!) will display. Move your mouse over the ! to display details of the error. Each dialogue is described below.

**Origin**

For an **Origin**, specify how many agents to create and over what time period you would like them to generate (immediately, after a delay or gradually). If you select **origin**, a menu will display asking for this information.

The following fields can be set:

**Name**: Of the Origin.

**Min Premovement Time (s)**: The minimum time before which no agents will have moved (in seconds).
**STEP TWO: ASSIGN SIMULATION OBJECTS**

**Max Premovement Time (s):** The maximum time by which all agents will have moved (in seconds).

**Sorted Birth Cells:** If selected, agents will be sorted in this Origin (see example below). By default this setting is selected, since sorted generation is less CPU-intensive than random distribution.

**Generate From (s):** The time at which the first agent is generated (in seconds).

**Generate To (s):** The time at which the last agent is generated (in seconds).

**Number of Agents:** Per Origin.

*Example:

A total of 20 agents are generated in the Origin within the first second. Each has a response time of between ten and twenty seconds. I.e. the first agent moves only after ten seconds.

*Example: Sorted Birth Cells vs. Random Distribution

If **Sorted Birth Cells** is selected, each agent has the same "comfort distance" between it and any other agent. As such, a uniform emergence occurs. (This results from a Behavioural Settings change in **Comfort distance for origins**). Otherwise, agents are randomly placed in the Origin.

**Destination**

By selecting **destination** the following menu will display:
CHAPTER 4. STEP-BY-STEP MODELLING PROCESS

You will see the option: **Disable Dynamic Flooding**. Dynamic flooding of a destination affects the performance and quality of your simulation. Essentially, with dynamic flooding your simulation will be more realistic but slower to run. For test cases or simple simulations dynamic flooding can be disabled to speed up simulation time.

If you wish to switch off dynamic flooding for all Simulation Objects use the Simulation Settings menu and set the property **Use dynamic floor field** to **FALSE**.

**Scaled Area**

With **Scaled Areas** agents’ speeds can be adjusted, modelling ramps or undesirable areas etc. Use **Scale** to decelerate by some factor (<1) or to accelerate by some factor (> 1).

By selecting **scaledArea** from the menu, you will be asked to specify your acceleration factor.

*Example:* By setting the acceleration factor to 0.7, all agents would decelerate to 70% of their desired speed.

**Directed Scaled Area**

**Directed Scaled Areas** accelerate and decelerate agents according to their direction of travel. This represents, for example, ramps or simplified stairs (upwards vs. downwards).

After selecting **directedScaledArea**, choose the direction of the acceleration field (in regards to its x and y coordinates). Following this, specify the acceleration factor in both directions (e.g. one direction slower than the other perhaps).

*Here a Directed Scaled Area is created that accelerates an agent to 1.5 times its desired speed if it travels from left to right. If an agent travels from right to left,*
it will slow to half its desired speed through this area.

To change the direction of the acceleration field, it is also possible to use the tool icon. The tool icon will cause a frame to popup, in which you are able to specify the direction of your acceleration field by clicking directly on the circle on the upper half of the frame or by entering the degree of the direction vector in the lower half. In either case, the new direction will automatically translate to the \((x/y)\) form.

**Waiting Zone**

To create a Waiting Zone, right-click on a Simulation Object without an assigned function, select `waitingZone` and set the following variables:

- **Capacity**: The number of agents who can reside in a Waiting Zone at the same time. If you wish there to be no capacity constraint, set this value to "-1".
- **Time To Wait**: Offers the time in seconds for which agents will wait.
- **Distribution**: The distribution of the deviation of the waiting time (normal or uniform).
- **Deviation**: If the waiting time deviation has a normal distribution, this value represents a standard deviation. That is, if Time To Wait is set to 8, Distribution normal and Deviation, we will have waiting times with mean 8 seconds and standard deviation 2 seconds. If the waiting time deviation has a uniform distribution, this value represents the range either side of Time To Wait. That is, if Time To Wait is 8, Distribution uniform and Deviation 2, we will have waiting times uniformly distributed between 6 and 10 seconds. If your selection would generate negative waiting times, an error message will display. If you would like no distribution, set the value to '0'.
- **Reoccurring**: Here you can set some time (in seconds) after which the
capacity of your Waiting Zone will renew. That is, your Waiting Zone is not closed. If you do not wish for this consideration, set the value to '0'.

For the example above: four agents can enter and must wait for eight seconds. After three seconds however, another four agents can enter who must also wait for eight seconds. The first group will leave five seconds after the first arrived.

Should your Waiting Zone 'restart' after a period of time, that is, should it empty and refill, such intervals can be assigned, see Intervals. You could assign these intervals as a representation of trains, for instance.

Note: For Waiting Zones with a capacity of one, groups are counted instead of the individual members. If a group of three is next in line to enter a Waiting Zone of capacity one, they will enter together. This behaviour can be used to model payment counters. E.g. a family of three buying cinema tickets all at once, while three people not belonging to the same group buy their tickets one after the other.

**Queuing Area**

A Queuing Area can be ordered or unordered. Ordered Queuing Areas are defined by a line and a Waiting Zone. Right-click on a line and select Queuing Area. You can now give this Queuing Area an object to queue for, i.e. an agent’s desired destination once it has reached the front of the queue. To do this, select from the drop down menu under Waitingzone to queue for.

![Queuing Area settings](image)

The 'Waitingzone to queue for' can be altered later by right-clicking on the Queuing Area and selecting Set Waitingzone to queue for...

![Queuing Area settings](image)

The resulting queue will look something like this:
**STEP TWO: ASSIGN SIMULATION OBJECTS**

**Note:** If agents are queueing for an object, the Queueing Area (a line in this case) represents a 'stop point', with the queue growing perpendicular to it. (Advanced: Small deviations from a straight line queue can be selected in Behavioural Settings under **Max queue derivation**. The distance between each agent in a queue can be specified similarly under **Comfort distance in queue**).

If no object to queue for is specified, an unordered queue will form along your Queueing Area line (see: Our Queueing Model).

*Below is an example of a Queueing Area without an object to queue for:*

*And here is an example of a Queueing Area with an object to queue for:*

**Stair**

To create **Stairs**, right-click on a rectangular Simulation Object and select **stair**.

**Note:** Stairs can only be created on rectangular objects. If **stair** is unavailable (greyed out), your Stair geometry is not rectangular. Change this in your CAD software.

Besides the orientation of the Stairs, you can change the number of treads. You will get warnings if the number you entered translates into invalid tread widths (minimum is 0.15m, maximum is 0.4m, default is 0.25m) given the Stair’s overall length.
Use the Turn 90° button to change the orientation of your Stair. The arrow drawn on the Stair indicates its upward-facing direction. The Stair in the previous screenshot has its lowest z-coordinate on the left side, and its highest on the right.

A new Stair will not automatically connect to another floor. If unchanged, agents will traverse the Stair (given it lies on their path), but will not move to another floor. Select which floors to connect to under, Connects to floor.

Once your Stair connects to another floor, it will become partially translucent and the Flip sides button will appear:

This depiction implies the Stair has its lowest step on the displayed floor and its highest step on floor ‘flo1’.

After pressing the Flip sides, the stair looks like this:

Now the Stair has its lowest step on ‘flo1’ and its highest step on the displayed floor. Flipping sides changes whether a Stair is attached on top of the displayed floor (default), or below it.
**Escalator**

As with Stairs, Escalators can be assigned only to rectangular objects. As always, right-click on your Simulation Object and select escalator.

The minimum tread width is 0.3m, the maximum 0.8m and the default is 0.4m.

Escalators have three options more than stairs:

- **# of landing treads** defines the number of treads that remain horizontal at each end of an Escalator - allowing agents to safely enter and depart. Landing treads allow agents to move freely before selecting a lane.
- With **Speed in m/s** you can alter the Escalator’s speed.
- Change the Escalator’s direction of travel using the **Flip travel direction** button.

Here, the Escalator is lowest on the displayed floor and highest on floor ‘flo1’. The travel direction is upwards, meaning agents enter on the displayed floor and travel to flo1.

If a Stair or Escalator doesn’t meet your modelling-needs because you need a non-rectangular stair or one that can be entered from the side - use a Scaled Area or a Directed Scaled Area instead.

**Elevator**

An Elevator connects multiple floors. Adjust an Elevator’s **Boarding time** and **Capacity** in the dialogue’s respective fields. Using the **Journey-times matrix**, deselect unattainable floors under **Floors this elevator stops on**, and in the matrix, describe the travel times between each floor pair. The 'home'-floor (upon which the elevator’s geometry sits) is always a stopping floor.

Below, the 5.0 in row 1, column 2 means the Elevator will take 5 seconds to travel from flo0 to flo1.
Note: Be sure an Elevator can reach every floor required if it is included in a Path.

Portal (Legacy)

The following is out-dated. Instead, use Escalators, Stairs or Elevators.

**Portals**, displayed as a line, link two floors. They represent the 'end' of a floor. If you cannot select portal, it means there is no other floor in the scenario. Another floor must be created and imported before you can add a portal.

Note: If you wish to combine Stairs and Portals, the Portal must lie on the first or last step of the Stair, i.e. on one of the bounding lines of the Stair’s rectangular geometry.

To create Portals: right-click on a Simulation Object line and select portal.

The following menu will appear:

Here the name of the floor to which you wish to connect the current floor must be specified. In addition, an arrow will appear over the Portal. This indicates the direction of the Portal’s entrance (i.e. agents should walk into the Portal in this direction).

In order to change the direction of the Portal, right-click on your Portal or use the Portal’s menu.
Step Three: Create Simulation Parameters

Paths in the GUI

Paths specify an agent’s targets, and are used in processing its route. Every Path must start at an Origin and end at a Destination. An agent without an assigned Path remains in its Origin throughout the simulation. Every Path is assigned a probability (between 0% and 100%), which determines how many agents will take that Path, given other Paths begin from the same Origin.

The shortest and simplest Path is a direct connection from Origin to Destination. However, a Path can contain any number of intermediate targets: Simulation Objects that agents visit in order. The following Simulation Objects can be intermediate targets:

- Destination
- Origin
- Waiting Zone
- Queuing Area
- Stair
- Escalator
- Elevator
- Portal (Legacy)

Things become more complex (and interesting!) when Sets and PathSnippets lie on your Paths. PathSnippets represent parts of a Path that can be included in multiple Paths as an intermediate section of each. See: Sets for a definition of a Set. Paths and PathSnippets follow the exact order they are given. Note: PathSnippets can contain Sets, and Sets can contain PathSnippets. This can result in potentially high levels of complexity. However, with prudent use, this functionality is extremely useful for sophisticated modelling.

It is important to note again that Paths must begin with Origins and end in Destinations, regardless of the number of Sets, PathSnippets and intermediate targets. So, if a Path begins with a Set, that Set must contain only Origins. Similarly, if a Path begins with a PathSnippet, that PathSnippet must begin with an Origin or an Origin-set. Respectively for Destinations.

In some cases, your Path must place certain Simulation Objects in order. For example, a Queuing Area needs a subsequent Waiting Zone to function. To switch between floors, use Stairs, Escalators or Elevators.

Creating Paths

Every new Path begins with a right-click on an Origin. (As appose to PathSnippets, which can begin from, and be attached to, any Simulation Object.) The following menu will display:
CHAPTER 4. STEP-BY-STEP MODELLING PROCESS

If an Origin is part of an Origin-set, a new Path can be started here as well.

Now, further Simulation Objects can be placed on the Path or the PathSnippet. If you select a Simulation Object that is part of a Set or a PathSnippet, these will be added to the Path. However, if a Simulation Object is not part of a Set or PathSnippet, the following will display:

Each Path must end in a Destination (be it a single Destination, a set of Destinations, or a PathSnippet(s) ending in Destinations).

At the point you select the Path’s termination point (directly or via PathSnippets or Sets), a menu slider requests the proportion of agents you wish to use this Path. Any number of Paths can begin from a single Origin, but the sum of their usage-proportions must be 100%.

Editing and Deleting a Path

If you move your mouse over a Simulation Object, a series of lines and proportions display identifying all Paths associated to this object. (Naturally, if an object is not part of a Path, no such lines display).
STEP THREE: CREATE SIMULATION PARAMETERS

To edit a Path, hover your mouse over the Path and right-click. The following will display:

If you select **Delete path**, this Path will delete. Remaining Path proportions are not re-distributed. With **Edit ratio** you can alter the number of agents who use each Path.

**Editing via the Menu**

We have now reached the middle section of the **Edit** Menu, which we recommend working through from top to bottom. Each menu item is a building block for the simulation.

There are three main building blocks that must always be assigned (all other menu items are optional):

- Interval
- Interval-Matrix
- Paths
Selecting a menu item will open a window displaying the relevant table. Each row and row-element can be edited, and right-clicking will allow you to add or remove rows. In the case of invalid input, the corresponding cell or the whole line turns red. A message will appear when your mouse rests over the invalid cell.

The tables can be filtered by pressing the right mouse button on the header of the table.

### Intervals

Here the number of agents engaging with a certain Simulation Object (be it an Origin, Destination, Waiting Zone etc.) can be defined. The first column is the name of the interval. The second column is the time at which the first agent engages with the Simulation Object. The third column is the time at which the last agent engages with the Simulation Object. The final column is the number of agents you wish to have engaged with the Simulation Object.

**Example:**

<table>
<thead>
<tr>
<th>Name</th>
<th>Start (s)</th>
<th>End (s)</th>
<th>No. of agents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interval-Person-A</td>
<td>0</td>
<td>1</td>
<td>20</td>
</tr>
<tr>
<td>Interval-Person-B</td>
<td>0</td>
<td>100</td>
<td>100</td>
</tr>
<tr>
<td>Interval-Destination</td>
<td>0</td>
<td>?</td>
<td>?</td>
</tr>
</tbody>
</table>

Here three intervals are created. In the first interval, 'Interval-Person-A', twenty agents are created in the first second. In the second interval, 'Interval-Person-B', one-hundred agents are created evenly in the first one-hundred seconds. During the final interval, 'Interval-Destination', all agents are removed at any time from time zero.

### Interval Matrix

Here the intervals created in the *Intervals* table are assigned to Origins, Destinations, Waiting Zones etc. Enter the Simulation Object in the left column and the corresponding interval in the right column. A single interval can be assigned to multiple Simulation Objects. In each case, the number of agents specified in the Intervals table will be engaged with the Simulation Object. For example, if an Origin is selected, the final column of the Interval table represents the number of agents generated in this Origin.

**Example:**
**STEP THREE: CREATE SIMULATION PARAMETERS**

The previous example, in Intervals, is continued here with the requisite columns completed.

**Paths**

The Paths table displays each simulation Path. Each Path describes completely, from Origin to Destination, the route of an agent. Any number of intermediate targets can be defined for each Path.

The table’s first column offers the unique name of each Path. The second column determines the proportion of agents (who are born in the Path’s Origin) to use the Path. Naturally, if an Origin has only one Path, this proportion is 100%. The second column must in all cases distribute 100% exactly, for each set of Paths that commence from the same Origin. The final column displays each Path by route. That is, the names of each way-point (incl. Origin and Destination) of a Path are shown in order, separated by a comma.

*Example:*

See Visualize Hierarchy to get a tree-like visualisation of the contents of a Path.

**PathSnippets**

PathSnippets allow you to group together Sets, other PathSnippets and Simulation Objects. Unlike a Set, a PathSnippet is ordered, meaning if an agent encounters a PathSnippet on its overall Path, it will walk each of its elements in order. In a Set only one element will be selected based on the given heuristic.

See Visualize Hierarchy to get a tree-like visualisation of the contents of a PathSnippet.

**Sets**

Sets allow you to combine any number of Simulation Objects or PathSnippets and can be nested in one another. You may wish to use Sets for the following reasons:

- To allocate heuristics within Paths, i.e. agents need to go to a toilet, but it doesn’t matter which.
- To allocate properties to many PathSnippets simultaneously.
- To colour and evaluate the simulation based on a Set of Paths.
The following heuristics are possible:

**closest:** Agents seek the closest object within the Set. This is the default heuristic.

**lessCrowded:** Agents seek the least populated object within the Set, and then the closest of these.

**distributed:** Agents select uniformly any object within the Set.

**distributedAndEmpty:** Agents select uniformly any object within the Set, provided it has the capacity for them. For instance, you may wish to simulate seats by setting each seat as a Waiting Zone. Each seat must be empty to be selected by an agent.

**shortestQueueLane:** Agents choose a queue with the fewest number of people. Naturally, this is only appropriate if a set contains a Waiting Zone.

**fixedRatio:** Fixed values can be set, that define the distribution among the set members. The sum of the values per set must sum up to 1:

<table>
<thead>
<tr>
<th>Sets</th>
<th>ID</th>
<th>Heuristic</th>
<th>Members</th>
<th>Ratios</th>
<th>Referenced by</th>
</tr>
</thead>
<tbody>
<tr>
<td>Testset</td>
<td>Test1</td>
<td>fixedRatio</td>
<td>0.3</td>
<td>0.2</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Test2</td>
<td>fixedRatio</td>
<td>0.5</td>
<td>0.2</td>
<td></td>
</tr>
</tbody>
</table>

To add a Simulation Object to a Set, right-click the Simulation Object and select **Add to set...**. The menu that follows allows you to add the object to an already existing Set, or create a new one by pressing the create new set button:

When creating a new Set, remember to select a relevant heuristic.
STEP THREE: CREATE SIMULATION PARAMETERS

To add a "micro" Set to a "macro" Set, right-click on an object that is in the micro Set, and select Add set to set.

To remove a Simulation Object from a Set, right-click the Simulation Object and select Remove from set.... The menu that follows shows all Sets the current Object belongs to and allows you to remove the Object from them.

To get an overview of all the Sets you have, including assigned heuristics and set members, select Edit > Sets. Here you can edit, create and delete Sets. If insufficient or invalid information is provided (duplicate Set IDs, no heuristics or non-existent member IDs), the corresponding fields are highlighted in red and the corresponding line is deleted when the window is closed, unless the error is corrected.

In order to put a Set on a Path, click on a Simulation Object that is part of a Set to display the so-called "context menu":

CHAPTER 4. STEP-BY-STEP MODELLING PROCESS

As soon as a Set is on a Path, it is displayed in yellow in the SetsTable (Edit > Sets ...) and can neither be edited nor deleted. Similarly, Simulation Objects cannot be deleted if they are members of a Set that lies on a Path. Consequently, floors that contain such objects cannot be deleted.

Sets of PathSnippets are also available. The given Set-heuristic will determine which PathSnippet an agent selects when he comes to a "fork in the road".

See Visualize Hierarchy to get a tree-like visualisation of the contents of a Set.

Groups

Here we find the distribution of groups. The left column (Size) indicates the size of the group, and the right column (Ratio) describes the proportion of agents in a group of that size. Naturally, the ratios must sum to 1.0.

Example:

<table>
<thead>
<tr>
<th>Groups</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Size</td>
<td>Ratio</td>
</tr>
<tr>
<td>0</td>
<td>1.0</td>
</tr>
</tbody>
</table>

Visualize Hierarchy

In the Paths, PathSnippets and Sets table you have the option to see a tree-like visualisation via the context menu.

This view displays Paths, PathSnippets and Sets hierarchically. Each tree-entry may have its own table of sub-entries, which you can view by selecting that entry. Else, Simulation Objects will be highlighted if selected in the tree.
This can be used to get an overview if your Paths, PathSnippets or Sets are lengthy and complex.

Step Four: Settings

The first section of the Edit menu allows you to edit various simulation parameters. With the Settings options and careful use of Quick Select, your simulation can be refined as required.

Quick Select

With Quick Select..., the first menu item, a new window will allow you to select and alter several objects simultaneously.

The selection process works by applying a series of filters to your objects. The first filter is object type:

- simulation objects (assigned with type Origin, Destination, etc.)
- unassigned simulation objects
- sets (of Simulation Objects)
- path snippets
- paths
- evaluations
Sets, Path snippets and Paths can be renamed or deleted. Evaluations can be deleted.

For unassigned Simulation Objects, select Assign type to convert the selected objects to, for instance, Origins. A similar dialogue menu to the one seen in Step Two: Assign Simulation Objects will appear.

For Simulation Objects with assigned type, there are five possible actions you can take: Edit, Add to set, Create Evaluations, Rename and Delete. With Edit a dialogue menu will present the parameters for the first Simulation Object. Any changes made for this Simulation Object apply to all selected objects. **Warning:** parameters will be overwritten in this instance!

The Create Evaluations action creates Evaluation Polygons that precisely fit the selected Simulation Object’s geometry.
Settings

With the settings menus, you can alter a great number of your simulation’s parameters. If you choose not to set any parameters, default settings are applied. There are three distinct categories: Agent settings, Behaviour settings, and Simulation settings. The options for each are provided below:

Agent settings...

Deviation for velocity is the standard deviation of the population’s velocities [m/s] (default: 0.26)
Max velocity (m/s) offers the maximum walking speed of an agent [m/s] (default: 1.61)
Mean velocity (m/s) is the average speed of the agents [m/s] (default: 1.34)
Min velocity (m/s) offers the minimum walking speed of an agent [m/s] (default: 0.46)
Max torso radius (m) offers the maximum radius of an agent [meters] (default: 0.3)
Min torso radius (m) offers the minimum radius of an agent [meters] (default: 0.22)
Perception radius (m) is the perception radius of an agent, and is used to calculate density [meters] (default: 2)

Behaviour settings...

Comfort distance for origins (m) describes how close two agents may appear in an origin [meters] (default: 0.2)
CHAPTER 4. STEP-BY-STEP MODELLING PROCESS

Comfort distance in queue (m) describes how far apart two agents stand in a queue [meters] (default: 0.1) so that agents act naturally, up to 125% of this value may be considered by individual agents.

Max queue derivation describes the greatest angle, projected from an object, within which a queue can form for that object [0-180 degrees] (default: 30)

Queue width factor (m) affects the shape of queues [meters] (default: 1.0)

Simulation settings...

Cell size (m) describes how large each cell is [meters] (default: 2)

Compress output will zip the simulation output when checked (default: ON)

Dist between two points (m) is the distance between two evaluation points on the OSM disk [m] (default: 0.15)

Update rate floor field specifies the rate at which the dynamic floor field values should be re-calculated. The rate is per time-step, i.e. 1 means one calculation per time-step. By increasing the rate, the simulation is more realistic but computation time increases (default: 1)

Use dynamic floor field toggles an algorithm that makes the simulation far more realistic but increases computation time significantly (default: TRUE)

Use undirected floor field toggles an algorithm that speeds up simulation calculation when you have many origins or destinations (over 100) (default: FALSE)

Step Five: Simulate

Run simulation

With Simulation > Run simulation a new simulation will run.
STEP FIVE: SIMULATE

The following window will appear:

![Configure simulation run window]

Here, enter how many seconds should be simulated. Press Enter and the simulation will run, displaying a green progress bar with options Details... and Cancel. The simulation will terminate when all agents have reached their destination, the time has run out, or you select Cancel.

![Simulation progress bar]

Details... offers a further window, which displays information about the simulation’s progress. If a problem emerges, this window will also allow you to send a report to accu:rate.

Providing everything works, when the simulation has finished, the completed results will automatically open and the Simulation menu will change to the following:

![Simulation menu]

Statistic runs

It is often desirable to create several simulation runs from one scenario. This is possible with Statistic runs.

Here the simulation time must be set as usual, followed by the number of simulation runs. Simulation runs are then calculated one after another.

Once the final simulation is completed, it will automatically display, and the Simulation menu adjusts accordingly. An example menu is displayed below.
Continue editing

Once run, a simulation’s Simulation Objects and Paths may no longer be edited. Evidently, to edit them would create a discrepancy between the simulation results and the geometry from which the results were calculated.

If you do try to edit the simulation, the following appears:

You may:

- Delete all simulation results and edit file
- Copy this project without simulation results
- Cancel

In any case, simulation results can be deleted under Simulation > Delete results.

Step Six: Visualise

Having run a simulation of crowd behaviour, use in-built crowd:it tools to alter the visualisation of your results using the Visualize menu item. In this step, we will also discuss adding a background image, and how to create videos and photos.

Section One

Color agents by...

Here agents can be coloured according to certain characteristics. Characteristics include:

- **Neutral**: No characteristic affects the colouring.
- **Velocity**: The faster the agent, the lighter its colour.
STEP SIX: VISUALISE

- **Group**: With lines connecting each individual to every other individual in the group.
- **Group Size**: This is group size, not group.
- **Origin**
- **Destination**
- **Time of exit**: The sooner the exit, the lighter the colour.
- **Path**

Where appropriate, a legend will appear in the bottom left, clarifying the meaning of any colouring.

**Traces**

For ease, we have made it possible for you to visualise the literal paths of agents in real-time using Visualize > Traces.

The following display options are available, and may be combined. To:

- display all traces for agents still active in the scenario, select Visualize > Traces > Active agents.
- display all traces for every agent, select Visualize > Traces > All agents.
  To view a single agent, see: Identify Agents.
- colour the traces neutral, select Visualize > Traces > Neutral coloring of traces. (Otherwise, traces are the colour of the agent).
- allow any traces to fade with time, select Visualize > Traces > Fading traces. (Otherwise, the entire path will display).

![Traces](image)

**Section Two**

In the next section of the Visualize menu the following menu items are available:

- Visualize > Show legend (show/hide the legend in the bottom left of the display)
- Visualize > Show scale (show/hide the scale of the geometry in the bottom right of the display)
- Visualize > Show paths (show/hide Path lines)
- Visualize > Show pathSnippets (show/hide PathSnippet lines)
- Visualize > Show evaluations (show/hide Tripwires or other evaluation lines)

Each of these commands is independent of any other.

**Object label**

With Visualize > Show object labels... a dialogue window will open, allowing you to show or hide further labels. These labels cover all classes of object from
walls and unassigned Simulation Objects, to Origins and Stairs.

Simulation parameters

With Visualize > Show simulation parameters... the following will display:

![Simulation parameters](image)

These are the most important parameters. In order to see all simulation parameters, select Show Full Table.

Section Three

In Section three of the Visualize menu several options allow you to alter your simulation display in the Main Visualisation Window.

Menu items include:

- **Visualize > Graph** (display links between every Simulation Object as a connected graph)
- **Visualize > Cell grid** (display the grid upon which calculations were made)
- **Visualize > Background image** (display a background image if you have set one)
- **Visualize > Logo** (display a logo if you have set one)

Each of these commands is independent of any other.

Gray scale

You may wish to create grey-scale screenshots for which the **Gray scale mode** menu item is available. Here, you can select which grey-scale pattern should represent each object and space. To de-select, simply select **Gray scale mode** again.
Section Four

Set background image...

A background image set behind the scenario is sometimes useful. Since the dimensions of your image and scenario are unlikely to agree, it is possible to calibrate the size, position and rotation of your image. To do this, the image and scenario are displayed in two windows, each with a 'calibration line' drawn above them.

There are two ways to overlay an image onto your scenario. One option is to drag the corners of the calibration lines so that they both lie over a 'real' line respectively. That is, so that the image’s calibration line identifies the same real line as in the scenario. The second option is to adjust the calibration line in the simulation display itself. Since the image adjusts live, you can simply calibrate it by eye.

Finally, adjust the transparency of the image to avoid "visual competition" between the background image and the scenario. When you are happy, select Apply calibration.

Set logo...

With Visualize > Set Logo... you can add a logo to your simulation. Your logo will remain in the same position for each floor. By default, this is in the upper-right corner.
You can adjust the size of your logo by selecting it. This reveals a blue rectangle in each of the logo’s corners. Hold the mouse on one of these rectangles and drag the logo to the desired size. You can adjust the position of your logo by selecting the logo and moving it with your mouse.

Once you are happy with the size and position of your logo, exit editing mode by clicking anywhere outside the logo. To change the logo’s transparency, see Visualize > Logo.

The logo must be edited only once as it is a cross-project setting.

**Set zoom...**

You can zoom in and out of the simulation display by setting the zoom. Zoom ranges from 0.0 magnitude (fully zoomed-out) to 1.0 (fully zoomed-in).

**Set colors...**

You can alter the colour palette of your simulation under Visualize > Set colors.... Here you can change the colours of Simulation Object types, the background, the walls and evaluations. To change the colour of individual elements of the simulation, enter the element’s name in the available field. Else, right-click on the Simulation Object and select Set color....
STEP SEVEN: ANALYSE

Set animation speed...

You can speed up or slow down the simulation run time using Visualize > Set animation speed....

Step Seven: Analyse

Once your simulation is complete, and any visualisation settings defined, you can evaluate your results.

Agents

In crowd:it it is possible to analyse the behaviour of individuals and groups of individuals. The following menu entries describe how.

Identify Agent

Using Identify Agents you can consider individual agents and their personal details. After selecting Identify Agents, click on any agent you wish to know more about. A table displays the key data of the agent and a yellow trace displays the Path so far. To identify multiple agents, drag a rectangle over the agents you wish to highlight, or hold Control and individually select additional agents. De-selection is similarly available. When selecting multiple agents, three buttons display underneath the agents’ key data: <-, Statistics and ->. To navigate between each agent’s key data use the <- and -> buttons. To display statistics about all selected agents, select Statistics.

Example:
Search Agent...

If you are interested in a particular agent, and know its ID, use Search Agent... to locate it and display its details and Path as in Identify Agents.

Example:

![Search Agent dialog box]

Evaluation objects

To evaluate areas of your scenario, crowd:it provides various evaluation objects, as described in the following menu entries.

Tripwire

Tripwires consider how many unique agents have passed a line. You can count agents who move over the tripwire in one direction only, or in either direction. To count agents travelling in one direction only, specify the orientation as **Clockwise** or **Counter-clockwise**. An arrow will appear on your tripwire indicating the direction in which agents will be counted.

- Orientations include:
  - **clockwise**: counts agents that move clockwise across the tripwire.
  - **both**: counts all unique agents that pass over the tripwire.
  - **counter-clockwise**: counts agents that move anti-clockwise across the tripwire.

Select Tripwire to draw a line directly onto your plan.

A dialogue will then display, that edits the name, colour and orientation of your tripwire.

![Tripwire dialog box]

To see all options right-click on the tripwire:
STEP SEVEN: ANALYSE

This menu allows you to move, view, delete and alter the properties of your tripwire, respectively. By selecting **Move**, blue circles at either end of the tripwire can be used to move the tripwire. When you are satisfied with its location, click away from the tripwire.

If you select the option ‘Copy to floor...’, a new dialog will be opened. In this dialog you can select the floors to which this simulation object should be copied.

After applying, new simulation objects are created on the selected floors. These objects have the same properties as this simulation object.

You can also export screenshots and videos of the tripwire using this dialogue. Here, the bounding box of the tripwire is used as area for the screenshot or video.

Display a summary statistics including: number of agents passing over the Tripwire and times when the first and last agent pass the Tripwire, export the data of the tripwire to a **csv** file and create the following predefined charts:

- **Basis diagrams**:
  - **Number of peds**: the number of unique agents passing over the tripwire against time.
  - **Velocity**: offers speed statistics of agents at the point they cross the tripwire (minimum, arithmetic mean, median, maximum).
- **Weidmann Diagrams**:
  - **Velocity vs. Flux**
CHAPTER 4. STEP-BY-STEP MODELLING PROCESS

Rectangle

With **Rectangle**, you can create a box that acts like a tripwire with orientation both. The evaluating Rectangle can be drawn directly onto the plan and for editing options, see Tripwire.

In addition to the pre-defined charts associated with tripwires, Rectangles have:

- **Basis diagrams:**
  - **Density**: Voronoi density calculations within the rectangle’s area.
  - **Length per stay**: creates a data point each time an agent enters the Rectangle and records the length of stay of each visit.
  - **Aggregated stay**: provides one data point per agent and aggregates any time it spent in the Rectangle.

- **Weidmann Diagrams:**
  - **Density vs. Flux**
  - **Density vs. Velocity**

Polygon

With **Polygon** you can form a closed shape that acts analogously to evaluation rectangles. While creating your Polygon, any number of vertices can be added. Pressing **Delete** on the keyboard removes the last added vertex. To close the Polygon, simply click near the first point, or press **Enter**.

**Warning**: Polygons must be convex, otherwise evaluations will not be calculated. (A convex Polygon contains no corner that is directed inward.)

Charts

Use charts to quickly and clearly present the results of your simulation. You can select a pre-defined chart or create a custom chart.

**Create chart...**

Use **Create chart...** to create a custom chart. The following empty chart, an empty canvas, will appear:
Firstly, add data to your chart by clicking Select data.... The following will appear:

Select, on the left, a data type you wish to graph. Move this 'option' (on the left) to "selected" (on the right) by pressing the → arrow. **Note:** Only those data whose domain and range types are the same can be displayed on the same graph. As such, once a data type resides on the right, only those options on the left whose domain and range matches the selected data will display. E.g. If the selected data has "time" as their $x$-dimension, you will be unable to select data whose $x$-dimension is density.

Edit the settings of your data by selecting the appropriate cell in the table on the right. To remove data from your chart, press the X icon in the cell.

When selecting the settings icon, the following dialogue appears:
Here, you can set the legend, the colour of data points, specify whether a connecting line should be drawn between points and whether the area underneath this line should be filled, and specify whether data points should be identified with circles. Furthermore, statistical functions can be added to the chart:

- **Calculation function**: This drop-down menu determines, which statistical function is applied to the data.
- **Aggregation Window**: The calculation function is applied to a range of data points, using the aggregation window. Set this to zero, to consider only data points on the same x-value.
- **Continuous**: If this option is set, the calculation function is calculated for every x-Value.
- **Discrete**: Use this option to divide the domain of the data set into buckets. The calculation function is applied once per bucket. The aggregation window determines the size of each bucket.

**Imported**: If there is no data within a bucket the value of this bucket is set to zero.

It may take a while for your chart to display if crowd:it must process a large amount of data. Don’t worry, results are coming!
STEP SEVEN: ANALYSE

Configure your chart’s axes, size and title by clicking on each respectively, or use the **Chart** menu item. Here, you will also be able to switch to a stacked line chart. If selected, we recommend you colour the areas beneath each line so that there is no misinterpretation of the results.

Finally, export your chart as a **png** file with **File > Save as PNG...** or save the configuration with the star icon (see Reportings for further description). The chart will export as it is displayed.

Unhappy with your chart? Start over with **File > Reset chart**.

**Tripwire chart...**

Use **Tripwire chart...** to create a chart that displays the number of agents that have not yet crossed the corresponding tripwire. This can be used to create evacuation curves and compare emergency exits. The following can be determined:

- The times at which the first and last agents leave the evacuation.
- The number of escapees after a specified time.
- The flow of the evacuation based on the gradients and changes in gradients.

Select which tripwires to chart, and select **Create chart**.
Agents in scenario...
With this menu item, you are able to create a quick representation of the number of agents inside the complete scenario on all floors. This is useful for evacuation simulations to show when all agents have been evacuated.

Tripwire tour chart...
With Tripwire tour chart... you can identify the time taken to pass between two or more tripwires. For each row, only agents who pass each tripwire in the specified order are considered.

The output of your Tripwire Tour is the minimum, maximum and mean time in seconds between tripwires.

The menu items for Tripwire tour are:
- **Edit**: This allows you to specify the period of time over which you wish to observe.
- **Select tripwire**: See Tripwire chart....
STEP SEVEN: ANALYSE

Summary tables

Area summary...

provides a summary of each evaluation rectangle and polygon (an ’area’). Each area is detailed with:

- The mean number of agents in the area.
- The maximum number of agents in the area at the same time.
- The minimum, mean and maximum time spent within the area over all agents.

![Area summary table]

Tripwire summary...

provides a summary of a tripwire. It contains:

- The total number of agents counted.
- The time when the first agent was counted.
- The time when the last agent was counted.

![Tripwire summary table]

Path summary...

Still under Analyze you will find Path summary.... Here each Path is detailed with:

- The number of agents following the Path.
- The minimum, maximum and average times in seconds to complete the Path.

![Path summary table]

As with Tripwire tour chart... use Edit to specify the time of observation.

Heatmap...

Heatmap... overlays square tiles that are coloured according to some criteria onto your scenario. For the presentation of results, Heatmaps are invaluable.

You can specify the type of Heatmap you wish to display in the dialogue menu:
CHAPTER 4. STEP-BY-STEP MODELLING PROCESS

The menu is split into three sections:

- **Measurement**: In measurement, you can specify the Heatmaps type, time span, and tile size.
  - **Type**: Define the criteria for your colouring. Colour by:
    * **Density**: Over all time steps, the density of each tile is recorded. That is, the number of agents in each tile at any one time is averaged. (Mean or maximum density are available as comparison criteria between tiles). Density-Heatmaps can be coloured by Level of Service as defined by Fruin.
    * **Velocity**: Over the simulation run, the speeds of each agent entering each tile are averaged. (Minimum, mean or maximum velocities are available as comparison criteria between tiles).
    * **Agents**: Over all time steps, the number of agents entering each tile is counted.
    * **Mean length of stay**: Over the simulation run, the time each agent remains within each tile is averaged.
    * **RSET**: Required Safe Egress Time. The time at which the final agent passed the corresponding tile.
  - **Time span**: Specify the time in seconds over which you wish to calculate Heatmap values.
  - **Tile size**: Set the size of the measuring tiles in meters.

- **Colouring**: Here, a preview of the Heatmap’s legend is provided. If you wish to change the colouring, click the **Edit** button and a new dialogue will open.

- **Floors**: Define on which floors the Heatmap should be calculated.

If you are happy with your settings, click **Ok** to view your Heatmap.

**Colouring**: This menu is divided into four sections
STEP SEVEN: ANALYSE

• **Scheme:**
  - **Default:** The default colour scheme is white, blue, and black. It is either relative (the maximum value is set as the maximum achieved value) or absolute (the maximum value is set by the user).
  - ‘Custom’: A user-defined colour scheme. If you change any of the following settings, the colour scheme will become user-defined.
  - **Level of Service:** These colour schemes can be chosen for density Heatmaps:
    * **Walkway:** Service levels for walkways.
    * **Queueing:** Service levels for queuing.
    * **Stairways:** Service levels for walking on stairs.

• **Gradient:** Specify if the changes in colour are continuous or discrete.

• **Colour stops:** Here you can define the colour stops. First, determine whether to describe the colour values relatively (the maximum value is set in the dialogue) or absolutely (the maximum value is set as the maximum achieved value). Secondly, define the stops. Stops can be added, removed or edited.

• **Legend preview:** Here you can see the preview for the legend of the Heatmap.
You can close the Heatmap by selecting Clear from the above menu. To alter the Heatmap, re-select Create Heatmap....

Reporting

Often, you will need to simulate multiple scenarios of the same situation, outputting the same reports. In order to save time, crowd:it allows you to save your screenshot, video and chart settings. This feature is named Reporting. Reports can be viewed, re-opened, and re-exported across multiple scenarios.

Save report

Use the following button, found across crowd:it to save a report: 

You will be asked for a report name before the report is added to the list of your saved reports.

Saved reports...

All saved reports can be viewed, re-opened, re-exported and deleted under Analyze > Saved reports.... The following will appear:
You can select single or multiple reports to export or view by using the checkboxes. A double-click will open the relevant dialogue menu for that report.

The list of reports can be filtered using the search bar on top of the dialog.
Step Eight: Export

Once you have visualised and analysed your simulation, you may wish to export a video or screenshot of the results. Export your simulation to produce an overview of results, highlight certain time-steps or neuralgic points, or produce deliverables, such as heatmap displays and agent traces. Under crowd:it’s File menu, this is easily done.

Take screenshot...

Select File > Take screenshot... to set the file path and file name for a screenshot of the currently displayed time and floor.

Batch take screenshots...

Another menu item File > Batch take screenshot..., takes screenshots of multiple (or all) floors at the current time or at various intervals.

The following dialogue window will open:

Firstly you need to specify in which folder and with which prefix the screenshots should be saved. Afterwards you can select which floors and settings you wish to screenshot and specify whether the screenshots should be of the current time or over a series of intervals.

Once configured, you can save this report with the star icon (see Reportings for further description) and directly export it with Take screenshots.

Export video to file...

Finally, you have the option File > Export video to file.... Selecting this item will open following dialogue window:
Here you can specify in which folder and with which prefix your video will be saved; clarify which floors to show; select the time span of the video; and configure the visualisation settings, as in Batch screenshots dialog. Additionally, there is the option to **Follow traced agent**. This option will be available only if, in your main visualisation window, you are tracing a single agent (to do this see Identify Agents). When selected, the video will track that agent between floors. For example, if a traced agent is on Floor 1 for the first thirty seconds of your simulation and then on Floor 2, the video will similarly display Floor 1 for the first thirty seconds and Floor 2 for the remaining time.

Save your configuration using the star icon as ever (see Reportings) and directly create the videos with **Export**. *crowd:it* is locked during export.

After export, you can open and play the finished videos in a player. You will find in the lower-left of the exported videos the current second and the current number of agents in the simulation.

**Warning:** The video is **not** of the current display, rather, it is of the whole floor but at the current resolution.
Chapter 5

Project Work

Step-by-step example: "Grüne Wiese"

This small example works through a pre-designed project, from AutoCAD to crowd:it simulation.

AutoCAD

1. Open a new (empty) file.
2. Execute the command 'DWGUNITS' in the AutoCAD command line to set the unit measurement to metres to two decimal places. (Inputs: 6 > 2 > 2 > Enter > Enter > Enter > Enter).
3. Create two layers, one for origins and one for destinations. By convention, origins are red and destinations are green.
4. Create the project geometry using Polylines on the correct layers.
5. With the The crowd:it Toolbar click Add > Select the appropriate geometry > Enter > Assign a name to the object (e.g. origin1). Do this for all geometries you wish to be Simulation Objects in crowd:it.
6. Save the AutoCAD file.
7. With the The crowd:it Toolbar select Open with crowd:it to open your scenario in crowd:it.

crowd:it

1. Zoom-in so that everything is visible (scroll the mouse wheel upwards). Note that objects previously set as Simulation Objects and given names in AutoCAD now display orange.
2. Click on the top-left unassigned Simulation Object and create an origin by selecting Origin. Set Number of agents to, for instance, 42. Confirm with Apply.
3. Similarly, for the bottom-left unassigned Simulation Object select Destination.
4. Create a Path between your origin and destination. To do this:
   • Right-click on the origin and select Start new path with origin.
• Move the mouse to the destination so that a line appears between the origin and destination.
• Click on the destination and select End path with destination.

5. Finally, run the simulation via Simulation > Run simulation.... When prompted, save the simulation appropriately and select a simulation time of, for instance, '50'.
Chapter 6

The *crowd:it* Toolbar for AutoCAD (Legacy)

The *crowd:it* Toolbar represents the *crowd:it* plug-in. It is legacy software that need not be used, see Creating Simulation Objects. If you wish to use the plug-in, it can create and display Simulation Objects.

**Installation of the Plug-in**

The plug-in can be installed user-dependent or system-wide (such that all users of the computer can access it). Selecting user-dependent requires fewer permissions and is therefore preferred.

**User-dependent Installation**

Copy the folder "accurate-scengen.bundle" from the downloaded "*.zip-Archive" into the user’s Autodesk ApplicationPlugins folder. This can be found by typing "%APPDATA%\Autodesk\ApplicationPlugins" into the address-bar of Windows Explorer and pressing Enter.

With Microsoft Windows, the folder is usually located under
C:\Users\USERNAME\AppData\Roaming\Autodesk\ApplicationPlugins.

**System-wide Installation**

In order to install the plug-in system-wide, you require administration rights for your system.

Copy the folder "accurate-scengen.bundle" from the downloaded "*.zip-Archive" into the system-wide Autodesk ApplicationPlugins folder.

(With Windows 7, the folder is usually located under "C:\Program Files\Autodesk\ApplicationPlugins").
CHAPTER 6. THE CROWD:IT TOOLBAR FOR AUTOCAD (LEGACY)

Installation check

Regardless of whether you selected user-dependent or system-wide installation, restart AutoCAD once the folders are installed. This will provide you access to a new toolbox called ‘accu:rate’ in the Tool Palette window.

If the Toolbox window is not displayed, use the command line with command "TOOLPALETTES".

A source of error may be Express Tools in AutoCAD.

If you cannot see crowd:it in the AutoCAD Start Bar, and an error message (below) appears, the problem lies with Express Tools.

Error message: ActiveX server returned an error: Error loading type library/dll.

In this case, Express Tools must be de-installed and re-installed. See here.

Having trouble? Contact accu:rate (info@accu-rate.de/en/).

Components of the Plug-in

The crowd:it Toolbar has several functions that allow you to create objects that can be edited and simulated in crowd:it.

- **Add**: Here Polylnes can be converted to Simulation Objects. Select the Polylnes you wish to convert and click Add. Enter and confirm an ID for this Simulation Object in the command line.
- **Remove**: This item allows you to return Simulation Objects to their Polyline form. From here, you can remove them.
- **Identify**: With Identify you can query the ID of a Simulation Object.
- **Show all**: Select this item to mark all Simulation Objects. This allows you to have a quick overview of all assigned objects.
- **Save and Save as**