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Chapter 1

Preface

1.1 Disclaimer

This user manual introduces the user to the operation of the crowd:it software.

The models and algorithms implemented in crowd:it are derived from ac-

cepted and recent research literature. Nevertheless, accu:rate cannot assure

that reality will not deviate from any and/or all simulation results. The proper

use of crowd:it is the sole responsibility of the user.

1.2 Introduction

Congratulations! You have selected one of the most advanced pedestrian

simulators on the market. Founded in 2014, following studies at the Technical

University of Munich (TUM), accu:rate GmbH provides the latest research in

crowd simulation to practitioners including engineering firms, event organizers,

crowd managers and firefighters. Regardless of the scenario type; be it low

numbers of people in an office, or enormous industrial complexes, museums

and outdoor events, the state-of-the-art mathematical models at the core

of our software deliver valid results you can trust. With crowd:it’s clean and

self-explanatory user interface, you can focus on the project and not the

software.

The following documentation serves as a reference. Online video tutorials and

in-person training sessions are also available.
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CHAPTER 1. PREFACE

1.3 Document Structure

The document is divided into two main sections:

1. Description of the creation of microscopic simulations

2. Description of the creation of macroscopic calculations

1.3.1 Microscopic Simulations

The documentation follows the typical workflow of a project. Usually, this

begins with the simplification of CAD plans before certain objects and areas

are marked as simulation objects (e.g., entrances and exits).

For this purpose, commercial 2D CAD software packages, such as Autodesk™

AutoCAD, are suitable. Plans created in CAD software can be directly imported

into crowd:it.

Next, the movement sequences to be simulated and the paths of individu-

als (hereinafter referred to as agents) are modeled. Once the simulation

calculation is complete, the behavior can be analyzed.

Finally, results are generated and exported for further use.

1.3.2 Macroscopic Calculations

Macroscopic calculations are a simplified method for analyzing pedestrian

flows. They enable an initial estimation of evacuation times and can be used

in crowd:it exclusively for the calculation of evacuation scenarios.

The description also follows the typical workflow:

• No precise geometry is required for a macroscopic calculation. However,

it is recommended to import a floor plan of the scenario to be analyzed

as a background image.

• Various path elements and routes can then be defined.

• The calculation is performed instantly, and the results are displayed in

the right section of the user interface, where they can be analyzed and

exported.

We wish you great success with your crowd:it project!
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Chapter 2

crowd:it Introduction

2.1 User Interface

The user interface is divided into several sections, which are explained below.

2.1.1 General Menu Bar

At the top of the screen is themenu bar, which contains general functions:

On the far left is File. Here, you can open and save simulations or add a general

description to the scenario (which is displayed in the Information Panel).

9



CHAPTER 2. CROWD:IT INTRODUCTION

Next to File is View. Here, you can adjust general display settings, such as

showing a legend.

The following options are available:

• Legend: Shows/hides the legend at the bottom left of the display.

• Scale: Shows/hides the scale of the geometry at the bottom right of the

display.

• Background Image: Shows/hides a background image if one has been

set. A background image can be inserted as described here.

• Logo: Shows/hides a logo if one has been set. A logo can be set as

described here.

• Reset Toolbar: Moves the toolbar back to its original position at the top

left of the drawing area.

• Reset Floor Selector: Resets the floor selector to its original position at the

top right of the drawing area.

Each of these commands is independent of the others.

Under Help, you can access the menu items Open documentation, Shortcuts,

Get help from accu:rate, Quick intro for microscopic simulations, Quick intro for

macroscopic calculations, License details, and About. More information can be

found here.

2.1.2 Mode-Dependent Menu Bar

Below the general menu bar is a mode-dependent menu bar that allows

switching between different calculation modes.

The dropdown menu on the far left lets you switch between Microscopic and

Predtetschenski & Milinski ( macroscopic mode).

In Microscopic Mode, the following menu options are available:

• Visualize: Adjust visualization settings (see here).

• Simulate: Start simulations and manage results (see here).

• Analyze: Access tools for analyzing simulation results and exporting

screenshots and videos (see also here).

In Macroscopic Mode, the following menu option is available:

• Visualize: Adjust visualization settings (see here).

10
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2.1.3 Toolbar

The toolbar provides quick-access tools for editing and is displayed on the left.

It changes based on the selected simulation mode (microscopic or macro-

scopic).

Toolbar in Microscopic Mode

Depending on whether simulation results are available, the toolbar offers

different tools. The selection tool is active by default, allowing you to select

simulation objects.

The toolbar is divided as follows:

Select Objects (Both Edit and Result Mode)

• Select simulation objects

• Select walls

Edit Geometry (Edit Mode Only)

• Edit simulation objects and evaluations

• Simplify floor geometry

Draw NewObjects (Edit Mode Only)

• Draw and Assign new wall

• Draw and Assign new simulation object

• Draw and Assign Origin

• Draw and Assign Destination

• Draw and Assign Waiting Zone

• Draw and Assign Queue

• Draw and Assign Stair

• Draw and Assign Escalator

• Draw and Assign Elevator

• Draw and Assign Portal

• Draw and Assign Macroscopic area

Connect Objects (only in Edit Mode)

• Create Path

11
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• Create Path Snippets

Measure and Evaluate (both in Edit and Result Mode)

• Measure distances on the plan

• Draw Tripwire

• Draw Evaluation Rectangle

• Draw Evaluation Polygon

Select Agents (only in Result Mode)

• Identify single or multiple Agents

Toolbar in Macroscopic Mode

Select Objects

• Select simulation objects

• Select walls

Edit Geometry

• Edit object geometry

Draw NewObjects

• Draw wall

• Draw simulation object

• Draw start element

• Create corridor

• Draw stair up

• Draw stair down

• Create bottleneck

Connect Objects

• Connect way elements

Measure

• Measure distances on the plan

12



CHAPTER 2. CROWD:IT INTRODUCTION

2.1.4 Floor Plan View

The Floor Plan View displays the geometry of the simulation. Here, you can view

and edit your simulation and the associated geometry.

Navigate within the view by holding the scroll wheel or using the arrow keys on

your keyboard.

You can zoom in and out by scrolling with the mouse or using the slider located

at the bottom left of the floor plan view.

Next to the slider, you can center the floor by clicking on . The zoomwill adjust

so that the floor is fully visible.

2.1.5 Floor infos

The floor information is located at the top-right corner of the floor plan view.

Here, you can switch between floors, create new ones, or delete existing ones.

For more details, see here.

2.1.6 Playback bar

The playback bar only appears in microscopic mode when a simulation has

already run. It allows you toplay, pause, and rewind the simulation. Additionally,

the simulation can be played step by step. The timeline shows the current

time step, and the pointer can be moved forward or backward. The playback

speed can be adjusted under Visualize > Set playback speed ….

2.1.7 Information Panel

The information panel is located to the right of the floor plan view and displays

context-related information.

Information Panel in Microscopic Mode

Properties Tab

This tab is divided into two sections:

• Upper section: Displays general information about currently selected

objects.

• Lower section: Allows simulation-related settings.

13
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Upper Section

During the modeling phase, the upper section displays information about the

currently selected objects in the floor plan.

• If no object is selected, the total number of agents in the scenario and

per floor is displayed.

• If one or more objects are selected, a table with all currently selected

simulation objects appears.

A right-click on a table entry opens a context menu with further options.

If simulation results are available and one or more agents are selected in the

floor plan view, the tab shows specific information about these agents.

Lower Section

The lower section contains the following tabs:

• Project Description – Store metadata about the project.

• Personas – Define different agent groups (personas) (see here).

• Groups – Define various groups (see here).

• Evaluation (only visible if simulation results are available): Configure

detailed congestion evaluation settings.

Paths, Path Snippets, Sets Tab

Here, you can view and edit the existing Paths, Path Snipptes, and Sets in a tree

structure.

Result Tab (Only visible if simulation results are available)

This tab summarizes simulation results, including statistics on agents, sources,

and destinations.

2.2 Updates and Help

2.2.1 Documentation

Under Help > Open documentation, you can access the latest crowd:it docu-

mentation.

14
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2.2.2 Keyboard Shortcuts

Under Help > Shortcuts, you can view an overview of keyboard commands.

2.2.3 Help

2.2.4 Quick Intro for Microscopic Simulations

Under Help > Quick intro for microscopic simulations, a crowd:it file opens,

providing a fast introduction to using crowd:it.

2.2.5 Quick Intro for Macroscopic Calculation

Under Help > Quick intro for macroscopic calculations, you find a introduction

for macroscopic calculations.

Help via Hint Buttons

In many dialogs, you will find hint buttons marked with . Clicking this button

provides context-sensitive help and explanations.

Help from accu:rate

Under Help > Get Help from accu:rate, you can submit a support request. For

data protection reasons, project details are not included by default but should

be provided for faster assistance.

How-tos for a quick start

On our website, we offer several short how-tos to help you get started with

crowd:it. You can find them here.

2.2.6 License

Under Help > License Details, you can view and edit license information.
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2.2.7 Versions

Version Information

Under Help > About crowd:it…, you can view the current version of crowd:it and

the simulation core, as well as access the latest changelog.

Updates

Each time crowd:it starts, it automatically checks for updates. If available,

they are downloaded in the background. Once the download is complete, a

notification appears. Clicking it restarts crowd:it with the new version.

Version Conversion

Some updates require a new file format. When opening the application next

time, a dialog will appear for automatic conversion. The conversion is neces-

sary to continue working with the file. A new file is created, while the original

file remains unchanged.

2.2.8 Quick Intro for Microscopic Simulations

Under Help > Quick intro for microscopic simulationse, a crowd:it file opens,

providing a fast introduction to using crowd:it.

2.2.9 Quick Intro for Macroscopic Calculation

Under Help > Quick intro for macroscopic calculations, you find a introduction

for macroscopic calculations.

2.2.10 How-tos for a quick start

We offer several short how-tos on our website to help you get started with

crowd:it. These can be found here.

2.2.11 Help from accu:rate

Under Help > Get Help from accu:rate, you can submit a support request.

16

https://www.accu-rate.de/doku/en/howtos


CHAPTER 2. CROWD:IT INTRODUCTION

2.2.12 License

Under Help > License details, you can view and edit license information.

2.2.13 Updates

At each startup, crowd:it automatically checks for updates and downloads

them in the background.

2.3 General

The software includes some recurring behaviors, which are described in this

chapter.

2.3.1 Escape (ESC key)

Press Esc to cancel a running action.

The following actions can be terminated with Esc:

• Creating paths

• Creating simulation objects and way elements

• Drawing or moving measurement lines (tripwires) or polygons

• Tracking an agent

• Editing settings

2.3.2 Shortcuts

In crowd:it, various functions can be accessed via shortcuts. A complete

overview can be found in themenu bar under Help > Shortcuts…

2.3.3 Selection Behavior

Some elements, such as simulation objects, walls, and agents, can be selected

directly in the floor plan view.

The following basic conventions apply in crowd:it:

Left Mouse Click: Selecting Elements

There are multiple methods available for selecting elements. Objects can be

selected by simply clicking on them or by drawing a selection rectangle.
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Regardless of the method chosen, selection behavior can be influenced by

specific key combinations:

• Without an additional key: The current selection is cleared, and a new

selection begins.

• SHIFT key: New elements are added to the existing selection.

• CTRL key: Elements are added to the selection if they are not already

selected. If they are already selected, they are removed.

• SHIFT + CTRL simultaneously: Removes elements specifically from the

selection.

Selecting Multiple Elements

To selectmultiple objects at once, you candrawa rectangle around the desired

objects.

• Drag the mouse from left to right, and only objects that are completely

inside the selection rectangle will be selected.

• Drag the mouse from right to left, and objects will be selected even if only

part of them is inside the selection area.

Middle Mouse Click

• Amiddle mouse click on a simulation object allows you to edit its geome-

try.

• If the Select and Edit Walls tool is activated in the toolbar, the geometry

of walls can be adjusted with a middle mouse click.

Right Mouse Click

A right-click on a clickable object opens a context menu with quick editing

options that vary depending on the object type.

Left Double Click

A double-click on an object opens its properties.
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Copy and Paste

• Selected simulation objects and walls can be copied using Right-click >

Copy or Ctrl+C.

• They can be pasted at another position or on a different floor using Right-

click > Paste or Ctrl+V.

• The Copy to Floor option allows objects to be duplicated across multiple

floors simultaneously.

2.3.4 Probability Distributions

For generating different groups of people (personas), probability distributions

are required, for example, to assign speed, space requirements, or reaction

time.

The following types of distributions are available in crowd:it:

• Normal Distribution: Values follow a Gaussian distribution (bell curve),

meaning average values occur more frequently than extreme values.

• Uniform Distribution: All values within a defined range are equally likely.

• Log-Normal Distribution: Most values are concentrated on the left side of

the distribution scale. This distribution is well suited for modeling reaction

times.

• No Distribution: All objects receive the same fixed value.

2.3.5 Inserting a Background Image

A background image placed behind the scenario can sometimes be useful.

Since it is unlikely that the dimensions of your image and the scenario match

exactly, you can calibrate the size, position, and rotation of your image. To do

this, the image and the scenario are displayed in two windows, each overlaid

with a “calibration line.”

There are two ways to overlay an image onto your scenario. The faster method

is to adjust the calibration line directly within the scenario. Since the image

updates in real time, you can roughly calibrate it by eye. However, this method

only provides a coarse calibration. If you require a precise calibration, the

second method is better suited. Here, you move the ends of the calibration

line (red and blue) to a “real” line or corner in the image. It is helpful if the two

chosen positionVectors are far apart. Next, move the corresponding ends of
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the calibration line to the same line or corner in the scenario. The goal is to

match the exact same positionVector in both the image and the scenario as

accurately as possible.

Finally, adjust the transparency of the image to avoid “visual competition”

between the background image and the scenario. Once satisfied, select Apply.

2.3.6 Logo

You can add a logo to your simulation via View > Logo…. Your logo will remain

in the same position on every floor. By default, it is placed in the upper right

corner.

You can resize your logo by selecting it. This will make blue rectangles appear

in each corner of the logo. Hover over one of these rectangles and drag the

logo to the desired size. You can also reposition your logo by selecting it and

moving it with the mouse.

Once you are satisfied with the size and position of your logo, exit edit mode

by clicking anywhere outside the logo.

The logo can only be edited once, as it is a project-wide setting.
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Floors

Floors are used to define the simulation environment. This chapter explains

how to import, edit, and delete floors.

3.0.1 Insert

After creating a new simulation file, floors must be added for the agents to

move on.

• Clicking on allows you to import a .dxf file, which is then inserted as a

new floor in the project.

• Clicking on the icon creates an empty floor where you can draw your

own geometry (see Create Geometry).

Floors must have a unique name. If this is not the case, a warning is displayed,

and the import is not possible.

3.0.2 Replace

To replace an existing floor, right-click on it and select Replace. A file dialog

will open, allowing you to choose a new .dxf file. The existing floor will then be

replaced with the new file.

3.0.3 Viewing and Editing Properties

Double-clicking on a floor or right-clicking and selecting Properties allows you

to edit the following settings:
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• Name: The unique identification name of the floor.

Under Advanced, the following option is also available:

• Cell Discretization: Determines the grid size of the floor in meters.

3.0.4 Move

If the order of floors needs to be adjusted (e.g., when a basement is placed

above another underground floor), you can move the floor to the desired

position using the six-dot symbol ( ) next to the floor name via drag-and-

drop.

3.0.5 Delete

A floor can be deleted in two ways:

1. Using the trash bin icon .

2. Via the context menu (right-click on the floor).

If the floor contains simulation objects, a warning will be displayed before

deletion.

22



Chapter 4

Geometry

4.1 Create Geometry

In most cases, the geometry of a scenario is imported from a .dxf file, which

serves as a basis for modeling. A detailed guide on this can be found in the

chapter Importing Geometry from a CAD File.

Alternatively, geometry can be created directly in crowd:it. The DrawWalls tool

in the toolbar is available for this purpose:

This tool allows you to draw both open and closed walls.

4.2 Edit Geometry

Existing geometry can be changed as follows:

• : Changes the geometry of walls

• : Changes the geometry of simulation objects

… or with amiddlemouse click on the object.

The following steps can now be carried out:

• Select the object to be changed.

• After selection, the corner positionVectors of the object are displayed,

which can be moved by dragging.

• You can also select and move several corner positionVectors.

• With Ctrl + A all positionVectors can be selected to move the entire object.
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• The [Information panel][Info panel] also provides options to delete or add

new positionVectors between existing ones positionVectors.

4.3 Simplify Geometry

The toolbar includes the following tool , which can be used to simplify existing

geometry.

This tool performs the following simplifications:

• Removes inaccessible walls.

• Closes open walls.

• Merges redundant walls.

• Replaces walls with simpler geometric shapes.

The level of detail can be adjusted in the advanced settings. Further informa-

tion can be found in the user interface of the tool via the help button .

4.4 Tips for Creating Geometry

To ensure that two lines of a polygon are parallel:

1. Rotate the polygon so that one of the parallel lines is either horizontally or

vertically aligned.

2. Check the coordinates of the endpoints in the table on the right:

• If the line is horizontal, the y coordinates of the endpoints should be

identical.

• If the line is vertical, the x coordinates of the endpoints should match.

3. Adjust the coordinates of the two positionVectors that should be parallel

to the first line.

4. Rotate the polygon back to its original position.
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Microscopic simulation

The crowd:it software uses an agent-based model to simulate crowds – the

so-called Optimal Steps Model. Further literature on the model can be found

on our website at the following link:

Simulation model.

5.1 Themicroscopic modeling process step by step

The modeling process works as follows:

5.1.1 Step 1: Prepare the geometry

Before modeling can begin, a viewing area must be defined and a geometry

created. This can either be imported as a .dxf file or drawn directly in the

software (see also Floors and Prepare Geometry).
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5.1.2 Step 2: Modeling

In this step, all input data for the simulation is defined.

Required input data:

• The prepared geometry or the area of interest (see also Floors)

• Origins and destinations where agents enter and leave the simulation

(see also Origins and Destinations)

• Number and type of persons or population to be simulated (see also

Personas)

• Paths for controlling the agents’ movement from the origin to the des-

tination, provided that the option Run simple assessment has not been

selected (see also here)

Optional input data:

• Action plans (see also Paths): How do the agents move through the

simulation? Which stations do they pass?

• Further interaction objects on thewaybetween sourceand target, e.g. wait-

ing areas or queues

• Floor connectors such as stairs, escalators or elevators for multi-storey

simulations

5.1.3 Step 3: Simulate

Important settings can be made in the simulation menu, e.g. simulation time

or statistical runs.

After starting the simulation, the computer takes over the calculation.

5.1.4 Step 4: Analyze

After the simulation has finished, the results can be viewed. Various visualiza-

tion and analysis tools are available for this purpose (see also Visualize and

Analyze).

5.1.5 Step 5: Export results

Once the analysis is complete, all diagrams, statistics, screenshots and videos

can be exported and report templates can be created (see also Chapter

Export).

26



CHAPTER 5. MICROSCOPIC SIMULATION

5.2 Quick intro

Our Quick Intro, which can be accessed via theWelcome Screen or the Help

menu, introduces the basic crowd:it functions:

• Creating an Origin

• Creating a Destination

• Create a Path

• Run simulation

5.3 Prepare Geometry

To simulate agents in an environment, a floor plan of the area to be simulated is

first required. The plans should be created in CAD software and then imported

into crowd:it or drawn directly in crowd:it.

5.3.1 Drawing Geometry yourself

Here is explained how to draw and edit geometry on floors.
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5.3.2 Importing Geometry from a CAD File

dxf Format

Most CAD programs allow exporting .dxf files. These can then be imported into

crowd:it, ensuring compatibility with many different CAD programs.

Important!

To ensure that the exported files remain usable for the simulation, the identi-

fiers of the objects must remain unchanged, even during multiple exports or

adjustments. This is supported by most CAD programs.

Compatible and tested CAD software is listed here.

Elements with a special function in the simulation (e.g. origins, destinations,

stairs, etc.) can already be marked as generic “simulation objects” in the CAD

plan and assigned their specific function in crowd:it

(see Creating Simulation Objects).

These generic simulation objects can be created in several ways:

• Add the prefix “crowdit” (without hyphen) to the layer name in the .dxf file,

e.g., crowdit-stairs for stairs.

• Set the color of the layer or object to RGB 232/78/15 (Hex: #e84e0f).

• Directly create simulation objects in crowd:it using the Toolbar. You can

create a general object and assign it later or select a specific object type

(e.g., origin or destination) directly ( see Creating Simulation Objects).

Allowed Element Types

crowd:it recognizes the following CAD element types:

• Lines, Polylines, Circles, Arcs, Ellipses, Solids, Splines, LWPolylines, and

MLines.

• Elements within “blocks” are also imported.

• Elements like Hatch, Text, or Image are ignored.

Layer Organization

CAD files are divided into layers to structure elements and floors.

For better clarity, separate layers should be created for each type of simulation

object and each floor, e.g.:

floor0-crowdit-origins, floor0-crowdit-destinations.
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Note: Frozen layers are not imported into crowd:it. This can be used, for exam-

ple, to manage all floors of a building in a single file and only export relevant

floors by freezing unneeded layers.

A sample video on layer management in AutoCAD is available here.

Check Units and Scaling

To ensure consistent geometry and realistic simulation, plans must be to scale.

Check the units before importing.

To avoid problems, it is best to move the floor plan in your CAD program to the

origin. This ensures that coordinates are not too large when importing.

5.3.3 Preparing Geometry with Vectorworks

Since the .dxfexport fromVectorworks does not reliablyworkwhen re-importing

modified floor plans, a special plugin for Vectorworks is available.

The plugin is installed via the menu in Vectorworks.

Go to Help and open Install Partner Products. Here, crowd:it can be selected
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and installed.

The crowd:it plugin is automatically added to the menu under Tools -> Partner

Products -> Crowdit.

The plugin can also be added via Tools - Configure Workspaces.

Instructions for installing and using the plugin can be found here.

Preparing a floor plan for simulation is similar to the approach in other CAD

software.

Simulation objects can be created in the following ways:

• By adding crowdit to a class name.

• By using a Vectorworks database.

• By setting the color of the object (see also Creating Simulation Objects).

Creating Simulation Objects with a Database

Using databases means drawings do not need to be reorganized, as would be

necessary with class naming or color adjustment.

Using the Plugin

The plugin adds a menu item Tag as crowd:it simulation object.

Select the desired geometry objects and click this menu item to automatically

make all necessary database entries.

Assigning Objects to Classes

All objects placed in the crowdit class are automatically exported as simulation

objects.

Manual Creation

Create a database named dbase_crowdit with a boolean value crowdit-obj

set to true by default.

Every object in this database is recognized as a simulation object.
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Creating a Floor Plan from a 3DModel in Vectorworks

A 3Dmodel can also serve as a basis for a simulation in crowd:it, either through

multi-layer export or sections.

Multi-Layer Export

In a 3D model, all floors can be exported at once. The “Level Type” and “Storey”

must be entered for layers.

1. Considering Building Floors and Layers

• Use storeys to define correct building floors.

• Layers should be assigned to a storey to enable precise allocation.

Example: All objects on layer “1-Ceiling” belong to “1-Storey” and are exported

with the height of layer “1-Floor Layout” since this represents the finished floor

height.

2. Handling Cross-Floor Objects

• Objects penetrating multiple floors must be matched against the ex-

ported finished floor heights using their bounding box.

• If a collision occurs with multiple floors, the object is exported multiple

times.

31



CHAPTER 5. MICROSCOPIC SIMULATION

• Doors are recognized as wall openings. Special openingsmust be defined

as wall openings using the plugin.

Simulation objects are inserted as described above.

The multi-layer export can then be performed. Via the plugin - Export as

crowd:it floor, all floors are exported at once.

Export with Horizontal Slices

If projects were created without storeys and level types, they are not suitable

for multi-storey export.

1. Use Clip Cube to create a horizontal slice.
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2. Right-click on the section and select Create Slice….

3. In the new section, mark all objects and selectModify -> Convert to Group

to convert intelligent objects to simple geometry.

4. Copy these objects into a new document. Only construction layers are

exported to the crowd:it file.

5. Proceed as usual: create crowdit classes, add simulation objects, etc.

5.3.4 Simplify Floorplan

The cleaner a floor plan, the easier the modeling and faster the simulation

runs.

Every line in the file affects computation time. Simplification is particularly

useful for large simulations with many people.

After importing into crowd:it, geometry can be further optimized using the

Simplify Floor Geometry tool

(see also Simplify Geometry).

5.4 Creating Simulation Objects

After importing a floor plan file, all imported simulation objects are initially

marked orange.

A simulation object can be assigned as follows:

• Double click an element opens a selection dialog.

• Right click an object opens a context menu, where the dialog can be

initiated under Create….

If multiple simulation objects overlap, a menu will appear for selecting the

desired object. To manage several objects simultaneously, you can select

them as described here.

Additional objects can be individually added by left-clicking while holding the

CTRL key.

(See also Selection Processes).

The following simulation objects can be assigned:

• Origin: Generates agents within the simulation—either immediately or

over time.

• Destination: Removes agents from the simulation.
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• Scaled Area: Slows down or speeds up agents.

• Directed Scaled Area: Changes agent speed based on their direction.

• Waiting Zone: Defines areas where agents wait.

• Stairs: Creates stairs connecting two floors.

• Escalator: Creates escalators to connect two floors.

• Elevator: Creates elevators connecting multiple floors (available for two

or more floors).

Additionally, the following simulation objects can be created from lines:

• Queue: Marks the starting positionVector of a queue.

• Portal: Connects two floors as a type of “teleporter.”

For hybrid simulations, there is also:

• Macroscopic Areas: Aggregates agents into flows within a specified area.

You may retroactively change the type of simulation objects by right-clicking

it and selecting Change type… from the context menu.

5.4.1 Simulation objects settings

After selecting one of the above objects, a settings dialog appears.

It contains the following general information:

• Name: A meaningful name is advisable as it is reused as an identifier in

the results.

• Description: Space for additional information, notes, or comments.

…plus additional individual settings specific to each simulation object type.

Each dialog is described in detail in the following sections.

5.4.2 Origin

An origin generates agents within the simulation. Various parameters must be

set for this.

The dialog is divided into tabs for clarity. Typically, the first tab contains all

necessary settings.
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Generation Intervals Tab

Each origin can have multiple time intervals during which agents are gener-

ated.

The following information must be provided for each interval:

• From (s): Time of the first agent generation (in seconds).

• To (s): Time of the last agent generation (in seconds).

• Number of Agents: Total number of agents generated in this interval.

Personas Tab

Different pedestrian types (personas) can be defined here and their percent-

age share in agent generation can be determined. can be determined. New

Personas can also be created. An overview of all personas can be found on

the right in the Information area. Here, all existing Personas are listed and can

be edited.

Premovement Time Tab

Agents may have a premovement time — such as a delay before responding

to alarms.

During this time, they only avoid other agents (seealso [Waiting Behaviour][Tab

Advanced Settings]).

Settings options:

• Distribution: Probability distribution for reaction time can be defined ( see

Probability Distributions).

• Same for All Agents: When active, all pedestrians get the same reaction

time drawn from the distribution. More info available by clicking the hint

button ( ).

• If agents should move immediately, set reaction time to 0.

Advanced Settings Tab

Positioning

There are two agent placement modes selectable via the Sorted button:

1. Random Placement: No fixed arrangement (default).
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2. Sorted Placement: Agents are distributed on a regular grid evenly spaced.

Example:

Waiting Behaviour

Similar to Waiting Zones, various placement options for waiting agents during

reaction time exist, described in [Waiting Zone][Tab Advanced Settings].

5.4.3 Destination

Destinations remove agents from the simulation. For polygon-shaped des-

tinations, this happens when the agents enter the area. Alternatively, it is

possible to create destinations from line-shaped simulation objects. In that

case, agents reach the destination when they cross the line.

Advanced Settings

Optionally, custom intervals can be added (see here).

• Enable dynamic navigation:

Dynamic calculation improves simulation accuracy but increases simu-

lation duration. If you know that only certain parts of your scenario are

sensitive to congestions, it can make sense to enable this option for the

respective destination.

To disable dynamic navigation for all simulation objects, uncheck Use dynamic

navigation field at simulation start.
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5.4.4 Scaled Area

A Scaled Areamodifies the speed of agents, e.g., to model ramps or difficult

terrain.

• Scale: Defines how much agents are slowed down or sped up.

Example: A factor of 0.7 means agents run at only 70% of their usual

speed.

• Only for navigation: If activated, the area is considered during route se-

lection but does not affect actual speed.

Suitable for one-way streets or safety zones.

5.4.5 Directed Scaled Area

Directed Scaled Areas adjust agent speeds depending on their direction of

movement. Useful for modeling ramps or simplified stairs (upward vs. down-

ward).

• Direction: Specify the running direction as a vector with x and y coordi-

nates.

• Acceleration Factor: Determine speed for movement with and against

the defined direction.

To adjust the direction, use the tool icon ( ). This opens a window where:

1. Direction is set by clicking the circle in the upper half of the frame.

2. Alternatively, enter the angle of the direction vector in degrees in the lower

half.

The new direction is automatically converted into (x/y) form.

The option Only for navigation option can also be activated for directed scaled

areas. This is especially useful if you have areas that should be less attractive

to agents, but agents should not be slowed down. When activated, the area is

avoided but if an agent enters it, the speed is not affected.

5.4.6 Waiting zone

In a waiting zone, agents remain until they are allowed to leave.

The capacity of the waiting zone defines the maximum number of agents
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allowed.

If this option is not checked, there is no capacity limit.

Waiting condition

A waiting zone can be used in three ways:

1. Waiting time: Each agent waits for a defined duration.

2. Schedule: Agents are allowed to leave the waiting zone at specific times.

3. Event: Agents may leave the waiting zone when a specific event occurs.

While waiting, agents avoid passing pedestrians.

The avoidance behavior can be adjusted via the Advanced Settings.

Waiting time

Each agent is assigned a waiting time based on a predefined probability

distribution ( see Distributions).

Note: If groups are defined, and the capacity is set to 1, the number

of groups is counted, not the number of agents.

This only works for a capacity of 1.

• Example: If a group of three wants to enter a waiting zone with capacity

= 1, they will enter together.

This behavior is useful for modeling queue scenarios, e.g. a family buying

cinema tickets together, while three unrelated individuals buy them one

after another.

Schedule

Custom Intervals with variable capacities can be defined.

Agents may only enter the waiting zone during these intervals.

At the end of an interval, all agents leave the waiting zone.

This is suitable for scenarios like scheduled tours or events that start at fixed

times.
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Event

Agents wait for a specified event before they are allowed to leave the waiting

zone.

The following events are available:

• Meeting positionVector

• Crowd control

• Passenger exchange

Meeting Point

Agents wait until a predefined number of agents has gathered in the waiting

zone, then they depart together.

The number is set via the Capacity field.

Optionally, a time limit can be defined, after which agents leave the waiting

zone even if the group is not full.

This prevents agents from waiting indefinitely.

A detailed modeling description can be accessed via the help icon

Use cases: Group departure for school classes or tour groups in museums, city

tours, etc.

Crowd control

While waiting, agents monitor a designated area (either another Waiting zone

or a Destination).

When the number of agents or the density in that area falls below a threshold,

agents can walk on.

Optionally, a delay can be introduced requiring that no agents have entered

the observed area for a certain time.

Use cases:

• Dynamic access control to platforms or stations to prevent overcrowding.

• Regulation of crowd size in sensitive areas (e.g. entrances at events) to

avoid dangerous crowd pressure.
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Passenger Exchange

This event simulates a passenger exchange, e.g. at a train station.

Agents wait for an arriving train, allow others to disembark, then board the

train.

The train is represented by an Origin (for disembarking passengers)

and a Destination (for boarding passengers).

• The origin should cover the train cabin to ensure all exiting passengers

are generated.

• The destination should be on the opposite side (away from the platform)

to simulate correct boarding flow.

• Origin and destination areas may overlap geometrically.

Train schedules are defined via the Interval settings of the origin and destina-

tion.

The origin defines arrival timing, while the destination defines boarding time.

If no intervals are defined for the destination, agents may board at any time.

Optionally, a waiting period before boarding can be defined to avoid conges-

tion.

A sample setup is available via the help icon

Advanced Settings

Advanced settings allow fine-tuning of how agents behave in the waiting zone.

Waiting Behavior – defines how an agent must be positioned to be considered

“waiting”:

• Fully inside: The agent’s entire body must remain within the waiting zone.

• Center inside (default): Only the agent’s center positionVector must be

inside the area.

• Allowed to step outside: Agent may step outside during avoidance move-

ments.

Evasion Behavior – defines how waiting agents evade others:

• Don’t evade passing agents: Agent does not evade any others.

• Allowed to step outside (default): Agent may step outside the waiting

zone when avoiding.
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• Evade within area: Agent’s center remains in the area while avoiding

others.

5.4.7 Queue

Agents line up at a defined line to form a queue.

• Sorted: Agents queue in an orderly line. If unchecked, agents cluster

behind the waiting line without structure.

• Flip orientation: Defines the side of the line agents queue on, indicated by

an arrow in the preview.

The next element in the Path determines when agents leave the queue. Queue

modeling onlymakes sense when followed by a capacity-limited element (e.g.,

waiting zones or elevators). Otherwise, agents can always leave the queue. A

sorted queue looks like:

Additional adjustments:

• Maximum queue angle deviation can be set in Simulation Settings.

More details about the queueing model can be found here.

5.4.8 Stairs

Stairs can only be created from rectangular objects. If the Stair option is un-

available, geometry adjustments must be made either in the CAD file or using

the Geometry Tool.

• Number of treads: Adjustable within these limits:

– Minimum tread depth: 0.15 m

– Maximum tread depth: 0.4 m
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– Default: 0.29 m

• Rotate staircase:

– Change orientation via Turn 90°.

– Arrowon staircase indicates upwarddirection. The agents are slowed

downdifferently depending onwhether they are going upor down the

stairs. The deceleration takes place implicitly via the Optimal Stairs

Model and is continuously validatedusing the latest scientific findings.

The deceleration is not constant, but depends on the speed of the

agents in the plane. The agents walk downstairs faster than upstairs.

This is consistent with the scientific studies and the specifications

fromRiMEA. The agents are also slowed down depending on the tread

depth. The smaller the tread, the more they are slowed down.

• Connect floors:

– Newly created staircases do not automatically connect to other

floors.

– Select destination floor via Connects to floor.

• Modeled on floor: This shows the user where the stair resides, i.e. with

which floor it is associated. This helps to avoid confusion when modeling

more complex scenarios. It cannot be changed - if you want to associate

the stair with another floor, you need to model it explicitly on that floor.

Once connected:

• Agents switch floors mid-stair.

• Stair becomes semi-transparent, and Flip sides appears to determine

which floor each stair segment belongs to.

If a non-rectangular stair or a stair that can be accessed from the side is

required, a Scaled area can be used instead.

5.4.9 Escalator

Like stairs, Escalators require rectangular objects.

• Tread depth is specified instead of step count:

– Minimum tread depth: 0.3 m
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– Maximum tread depth: 0.8 m

– Default: 0.4 m

• Speed [m/s]: Sets escalator speed.

• Modeled on floor: Description see here

• Connects to floor: Makes the escalator a floor connector if specified.

Adjustments:

• Turn 90°: Adjust step orientation.

• Flip sides: Specifies floor for escalator segments when connecting floors.

• Flip travel direction: Changes escalator movement direction. The move-

ment direction is indicated by two arrows.

5.4.10 Elevator

Elevators connect multiple floors. Boarding time and Capacity can be set in

the settings dialog.

• Boarding Time: Elevator waits after an agent enters (similar to a sensor).

– Exception: If the elevator capacity is reached, it starts to move re-

gardless of the entry time.

• Floor Selection:

– Elevators stop on all floors by default.

– Floors can be deselected under Floors to stop on.

– The floor where the elevator was modelled can not be deselected.

• Journey Time Matrix:

– Sets individual travel times between floors.

– Include door opening/closing times for realistic simulation.

– In the simulation, the travel time is interpreted as the gross time

between “boarding time is over” and ” first agent exits the elevator

on the destination floor.”

• Set all journey times to:

– Uniformly sets all journey times.

Note: Ensure that the elevator can reach every required floor if it is

included in a path.
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Elevator Groups

If a group of elevators is to be modeled, a queue can be used to control the

waiting behaviour in front of the elevators.

• Combine elevators into a set.

• The selection process should be neutral, e.g., by using a threshold heuristic

where all elevators are set to ” Keep”.

• The functionality of selection processes is explained in detail here.

• The queue ensures that agents line up and use the next available elevator.

5.4.11 Portal

Portals can either connect two floors or represent a door/barrier within a floor.

They are modelled as lines. They can be used to:

• Define the end of a floor.

• Create a boundary within a floor (e.g., one-way streets, train doors, or

supermarket checkouts with a fixed walking direction).

The Connects to floor field specifies the floor to be connected. If left empty, the

portal functions, for example, as a train door or one-way street.

The Flip orientation option determines from which direction agents can cross

the portal. If they come from the other direction, the portal acts like a wall.

5.4.12 Macro Area

Amacro area aggregates agents into density flows and is suitable for areas

with unidirectional traffic where no congestion is expected.

This can speed up calculations.

Creating a Macro Area

1. Select the symbol in the toolbar .

2. Create a rectangular shape (the shape can later be converted into a

polygon using Edit Geometry).

3. A pop-up window will appear to enter a name and description.
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Defining an Entry Edge

• Amacroscopic area is unidirectional, so an entry edgemust be defined.

• Clicking on the red-marked lines changes the entry edge.

• If no line is marked in red, the geometry does not contain parallel lines —

this must be adjusted.

(Tips on adjusting geometry can be found here).

Important Aspects of Creation

• Entry and exit edgesmust be parallel.

• The exit edgemust be at least as long as the entry edge to avoid capacity

reduction and congestion.

• The zone should be bounded by obstacles on all other edges.

• No obstacles should be inside amacroscopic area, as they would reduce

the flow.

• Macroscopic areas do not need to be directly on the agents’ paths—they

function similarly to scaled areas.

• If a persona has a wide range of speeds, there may be deviations in clear-

ance time, as the macroscopic area always assumes the average of the

speed distribution.

Background information on the model is summarizedin this paper.

5.5 Paths, Path Snippets, and Sets

For agents to move in the simulation, they must be assigned paths. A path

describes an agent’s route from an origin to a destination and can consist of

path snippets, sets, and simulation objects.

• PathSnippetsare predefined route segments that canbe usedbymultiple

paths.

• Sets are groups of simulation objects, path snippets, or other sets, from

which one is selected either randomly or based on rules.

The following diagram illustrates this structure:
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The following sections provide a detailed description of the individual elements

and their associated selection processes.

5.5.1 Paths

A path defines an agent’s route through various simulation objects.

• Each path starts at an origin and ends at a destination.

• It may include any number of intermediate elements, such as:

– Waiting zones

– Queues

– Stairs or escalators

– Elevators

– Portals

– (Intermediate) destinations

– Origins

Important: An agent without an assigned path remains at its origin for the

entire simulation.

Composition of a Path

• Direct Path: A connection from origin to destination without stops.

• Complex Paths: Contain intermediate destinations, sets, or path snippets.

Difference between path snippets and sets:
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• Path Snippets (see Path snippets) contain multiple simulation objects in

a fixed order (AND-connection).

• Sets (see Sets) contain multiple simulation objects, from which one is

selected (OR-connection).

Note: Path snippets can contain sets and path snippets alongside simulation

objects, and sets can also contain path snippets and other sets – enabling

the modeling of complex scenarios.

Each path is assigned a probability:

• If only one path starts from an origin -> 100% of agents use it.

• Ifmultiple paths exist -> Ratios must sum to 100%. This is set via the Path

Table.

Key Rules:

• Pathsmust start at an origin and end at a destination.

• If a path starts with a set, the setmust contain only origins.

• If a path ends with a set, the setmust contain only destinations.

• A queue must be followed by an element (simulation object, set, path

snippet) with capacity constraints to allow agents to queue and wait for

availability.

Creating a Path

In Floorplan

1. Select the Path Tool in the toolbar .

2. Left-click on an origin: The path begins.

3. Add additional elements:

• Left-click on the object and select Add to path….

• If the object is part of a set or path snippet, you can add the object,

the set, or the path snippet.

4. End the path at a destination and select End path with….

In the Paths tab

1. Make sure the “Path” tab is open in the right-hand information panel.
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2. Enter a unique name in the field “Create new path” at the bottom.

3. Click on the Plus button or press Enter.

4. Now you may add elements to the path, see Editing a Path.

Alternatively, you can duplicate an existing path by right-clicking on it and

selecting Duplicate.

Path Ratio

Upon completion, a path ratio can be set. The default is 100%.

If multiple paths originate from an origin, the sum of probabilitiesmust be 100%.

This can be adjusted in the Path Table.

Multi-Floor Connections

If a path spans multiple floors, agents can:

• Explicitly use stairs, escalators, or elevators by adding them to the path.

• Useautomatic floor connectors: The systemselects the nearest connection

element to the destination. This setting is configured in the Simulation

Menu.

Editing a Path

The Paths tab in the right-hand information panel provides an overview of all

paths. Clicking on a path opens an editing panel below with multiple tabs.

• Members: Move elements within the path by dragging them over . Use

the search field to find sets, path snippets, and simulation objects and

add them with . Select elements and click to remove them.

• Settings: Rename the path or open the Path Table.

Path Table

The Path Table provides a tabular overview and allows:

• Editing all paths in text format.

• Filtering for specific elements.

• Adjusting path probabilities.
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Note: It is recommended to adjust only probabilities in the Path Table and

make other changes through the Edit Path section.

Each column contains:

1. ID: Unique and descriptive name.

2. Ratio [%]: Must sum to 100% per origin.

3. Members: List of elements traversed.

5.5.2 Path snippets

A path snippet is an ordered sequence of waypoints that can be reused across

multiple paths.

• Difference from a Set:

– A path snippet is traversed in a fixed order (AND-connection).

– A set selects one of its elements randomly or based on rules (OR-

connection).

Creation:

• Use the Path snippet Tool .

• Add elements by left-clicking.

All path snippets are listed in the Path snippets tab in the right-hand panel.

Here you may also create a new, empty path snippet. Clicking a path snippet

opens an editing area below with tabs:

• Members: Identical to path editing (see here).

• Probabilities: Set individual probabilities for path snippet elements.

• Settings:

– Capacity: Limits the number of agents assigned to the path snippet.

Default is unlimited (-1 in the table).

– Order:

* In order: Agents follow the elements sequentially.

* Permute: Agents traverse elements in a random order.

• References: Shows which paths and sets use the path snippet.

Alternatively, you can duplicate an existing path snippet by right-clicking on it

and selecting Duplicate.
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5.5.3 Sets

A set is a group of simulation objects, from which one is chosen for the path.

Sets can combine simulation objects, sets, or path snippets, allowing complex

nesting – one element is then selected based on the selection process.

Applications:

• Agents choose between different route options (e.g different destinations

or waiting zones).

• Agents can select among multiple path snippets.

• Multiple path options merge into one path.

Creating a Set

Right-click on a simulation object and select Set: Add…. In the dialog, create a

new set by entering a unique name under Create New Set and clicking .

Alternatively, you can duplicate an existing set by right-clicking on it and

selecting Duplicate.

Add Elements to a Set

Context Menu (Right-click on Object):

• Case 1: Object is not yet in any set -> Add to set…

• Case 2: Object is part of a path snippet -> Set: Add…, then choose between

object or path snippet.

• Case 3: Object is part of a set -> Set: Add…, then choose between object

or parent set.

Via the “Sets” Tab in the Information Panel on the right:

If no Set is selected, there is an option at the bottom to Create new set. Enter

a unique name into the field and click the plus icon to create an empty

set, which will then be displayed in the overview. Elements can be added by

clicking on the set.

Edit Sets

Through the Sets tab in the Information Panel on the right side of the user

interface, you can view all Sets created in the simulation. A left click on a Set

will display various tabs at the bottom, including:
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• Members: The Members tab is identical to path editing (see also here)

and allows adding and removing elements from the selected set.

• Settings: Allows you to change the name and description of the set.

• Selection Processes: Lists all paths, path snippets, and sets where the

selected path snippet appears directly or indirectly. A detailed description

of the available heuristics can be found here.

• References: Lists all paths, path snippets, and sets where the selected set

appears directly or indirectly.

For a hierarchical representation of the set, see here.

5.5.4 Selection Processes

When an agent reaches the last path element before a set, they choose an

element from that set as the next destination. A heuristic determines how

available elements are selected.

Available heuristics include:

• Closest: Selects the spatially nearest element.

• Farthest: Selects the spatially farthest element.

• Shortest queue lane: Selects the queue with the fewest agents. If multiple

queues have the same number of agents, a random queue is chosen.

• Shortest and closest queue: Selects the shortest and nearest queue.

• Distributed: Selects all elements equally.

• Distributed and empty: Selects only empty elements (e.g., unoccupied

waiting zones) equally.

• Less crowded: Initially selects the nearest element; if the person density

exceeds 1.2 persons/m², a farther element is chosen.

Creating Custom Heuristics

By clicking on “Edit”, you can define custom selection processes for the ele-

ments of a set.

A newwindow appears where you can define the selectionmode and selection

processes.

The following relationships exist:

• A selection mode determines how the elements of a set are chosen.
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• A selection process is a combination of selection modes applied sequen-

tially.

• Multiple selection processes can be defined for a set, each active during

a specific time frame. The time frames cannot overlap, meaning only

one selection process is active at any given time.

Selection Processes

The following actions are available:

• Add Selection Process: Enter a name in the field “Create New Selection

Process” and press to create a new selection process.

• Delete Selection Process: To delete a selection process, select a process

and press .

• Duplicate Selection Process: To duplicate a selection process, select a

process and click .

• Rearrange Selection Processes: Clicking opens a window where pro-

cesses can be reordered. Note: The times (“Active Until”) of the selection

processes remain unchanged; only the processes themselves are rear-

ranged. To return to edit mode, click the wrench icon .

For each selection process, the following can be set:

• Name: Double-click in the table field to change the name.

• Active until: Specifies the time until which the selection process is valid. If

only one selection process is defined, this field defaults to “End of Simula-

tion” and cannot be changed. Additional processes enable time adjust-

ments. The processes must cover the entire simulation period; otherwise,

agents may stop moving when the process expires.

Selection Mode

To define selection modes during a selection process, first left-click on the

table row.

All defined modes appear as a list at the bottom.

Delete a Selection Mode

Click to remove a mode from the list.

Reorder Selection Modes Click the double arrow icon at the bottom left to

open a new window where selection modes can be sorted. Click the six dots
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next to a mode name to move it. Click the wrench icon to return to edit

mode.

Add a Selection Mode

The following selection modes are available:

• Best: Selects the best element based on specific criteria.

• Demand: Selects the element with the lowest demand value.

• Threshold: Selects elements that do not exceed a specified threshold.

To add a mode to the list, press the corresponding button.

Selection Mode: Best

The Bestmode selects the “best” element based on chosen criteria and dis-

cards all others, typically leaving only one best element.

Available options:

• Number of agents: Selects the element with the fewest assigned agents.

• Distance: Selects the nearest element. Choose “Farthest” to select the

farthest element instead. Three measurement methods are available:

– Linear distance: Measures the distance to each set element (default).

– Walking Time: Evaluates how long an agent needs to reach each

element (e.g., to include scaled areas).

– Distance to projection on object: First calculates the projection of

each set element to the object’s outer edge where the agent is lo-

cated, thenmeasures the distance from the agent to these projection

positionVectors. This is useful when target elements are unevenly

spaced and agents should pick the one in their movement direction.

• Delay Time: Selects the element that delays the agent the least.

• Priority: Assigns apriority/order to eachelement. In “Best”mode, elements

with the lowest priority are chosen. For example, elements with priority 1

are preferred over those with priority 2.

Selection Mode: Demand

The Demand mode operates similarly to the Best mode: it selects a single

element that is the best according to the specified criteria. However, the

demand mode allows these criteria to be set individually for each element. To
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compare the elements, a demand value is determined for each member. The

demand value represents the distance to the defined threshold of the element.

The element with the lowest demand is selected. Right-click on a member

and select a demand type from the popup to define the criteria by which the

demand should be determined.

The following demand types are available:

• Default: Elements in the standard category are either discarded or not

discarded by the mode.

• NumberofAgents: Elements in the demand category are evaluated based

on the number of agents. The demand of an element reaches 100%

once the number of agents assigned to the element, as specified in the

“Threshold” column, is reached, and it is then discarded.

– “At the same time” / “Total”: This option allows you to specify whether

only the agents currently assigned to the element (at the same time)

or all agents who have ever visited it (total) should be counted for

the demand.

– “Absolute” / “Relative”: With the “Absolute” option, the number of

agents is specified directly. With ” Relative,” the mode is calculated

as a percentage.

• Delay Time: The demand reaches 100% once the agent is delayed by the

element for the time specified in the ” Threshold” column.

• Density: The demand reaches 100% when the current person density in

the element (in agents per square meter) reaches the value specified in

the “Threshold” column.

Selection Mode: Threshold

Unlike the Best and Demand modes, the threshold mode does not compare

elements with each other but against a threshold value. Each element can be

assigned a category and a threshold. The mode then discards all members

that exceed their threshold. As a result, multiple elements may remain, which

can then be selected through another selection process or randomly. The

same categories are available as in demand mode.

Additionally, there is the “Distance” category. By default, with the setting “near-

est,” it discards all elements that are farther than the specified threshold. Select
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“farthest” to choose elements that are farther away than the given threshold

while discarding the nearer ones.

The threshold mode typically discards all elements that exceed their assigned

threshold and returns the remaining elements. However, if all elements exceed

the threshold, no element would be returned. Therefore, you can specify what

should happen in this case. By default, the mode simply returns the element

closest to the threshold, even if it exceeds it. Other options include selecting

all elements (and letting the next mode decide which element to choose)

or discarding all elements (causing the agent to be unable to select a valid

element and thus stop moving).

Note: Some categories may be missing if the set contains members for which

the category is not applicable.

Selecting Multiple Best Elements

The “Best” and “Demand” modes offer the option to choose “Choose the best

N elements” at the bottom of the window. Normally, these two modes select

a single “best” element based on specific criteria. However, sometimes it is

beneficial to select multiple best elements, such as the three closest ones.

Use this setting to specify the number of best elements to be selected. Select

“more…” in the dropdown list to enter any number greater than zero.

Agents to Be Considered

All three selection modes offer the option to measure the number of agents

assigned to an element. Use the “Consider …” section to set the condition

specifying which agents should be considered. By default, all agents currently

assigned to an element are considered. Other options include considering only

agents who have reached an element or only those currently approaching an

element. The “Time Period” setting in “Demand” and “Threshold” modes must

be set to “at the same time” to enable the ” Consider…” settings.

5.5.5 Open HierarchyWindow

In the tabs Paths, Path snippets, and Sets in the Information Panel, you have the

option to open an additional window with a hierarchical view via the context

menu (“Open hierarchy window…”). This can be used to compare your paths,

path snippets, or sets if they are long and complex.
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5.6 Population Settings

In the right information panel under the Settings tab, at the bottom, you’ll find

the Personas** and Groups tabs, where you can make population settings.

5.6.1 Personas

Within the simulation, it is important to model the correct agent population.

To this end, the modeler must create one or more personas. Each persona

describes a group of people with similar characteristics. Classic personas

could be, for example, elderly people or students.

In the persona settings dialog, personas can be edited, created, and removed.

In crowd:it, a so-called DEFAULT persona is preconfigured, which is based on

values from the literature as an average population.

The values were derived from Weidmann as well as from the RiMEA Guidelines.

After creating the personas, the corresponding persona distribution can be

set for each origin.

A persona summarizes following characteristics of people, which will be ex-

plained below.

Torso diameter

The torso diameter describes the space requirements of a pedestrian. Each

pedestrian is modeled in crowd:it as a circle. To specify the required area, the

diameter must therefore be known.

To ensure that not all pedestrians within a persona are the same size, an

appropriate size distribution can be used. A more detailed description of the

distributions can be found here.

Speed

Speed describes the walking speed of a pedestrian on level ground. It repre-

sents the speed of the person without the influence of obstacles, other pedes-

trians, slopes, etc.

To ensure that not all pedestrians within a persona walk at exactly the same

speed, an appropriate distribution can be used. A more detailed description

of the distributions can be found here.
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Behavior

• Accessible simulation objects: This allows various types of simulation

objects to be excluded for a persona. If a simulation type de-selected,

agents with this persona will not use simulation objects of this type.

• Social distancing: The COVID-19 pandemic has prompted us to incor-

porate social distancing into our simulation model. Therefore, we have

integrated a social distance model that keeps agents a minimum dis-

tance from one another, if possible. The value can be set between 0

and 2.5 meters. More information about this model can be found at the

following link. In our implementation, agents try to maintain distance and

only violate social distancing if it gets too crowded or a bottleneck has to

be passed. If no social distancing should be maintained, the value can

be set to 0.

5.6.2 Groups

Here, we find the distribution of the groups:

• Size shows the size of the group

• Ratio describes the proportion of agents in a group of that size. The ratios

must sum to 1.0.

5.7 Simulation Calculation

5.7.1 Simulation Menu

Under the Simulatemenu, the following options are available:

As long as no simulation results are available, the following functions can be

used:

• Check simulation: Opens a window with analysis results from plausibility

checks. This check is particularly helpful for complex simulations to avoid

fundamental errors.

• Run simulation…: Starts a simulation. A window opens with configuration

options, which are described here.

• Run simple assessment…: Performs a simplified simulation without paths

(details see here).
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• Custom kernel…: Allows selecting a specific simulation kernel. This option

should only be changed in consultation with an accu:rate employee if

special simulation requirements exist.

If simulation results are already available, additional options appear:

• Delete Results: Removes the current simulation results.

• If statistical runs (see also here) have been performed, you can switch

between different simulation runs here to load the respective results.

5.7.2 Start Simulation

To start a simulation, click Simulate > Run simulation…. A window opens where

you can configure the simulation settings.

General Settings

• Simulation duration: Specifies the total duration of the simulation in the

time format hh:mm:ss. The simulation ends when either

– all agents have reached their destination,

– the specified time has elapsed, or

– you select Cancel.

• Number of simulations to run: Specifies how many times the simulation

should be executed. This allows statistical runs to be started, each per-

formed with different starting conditions (see also here).

• Agents to be generated [in %]: Defines how many percent of the agents

specified in sources will be simulated. This setting is particularly useful

for test simulations to verify the modeling.

Optional Settings

• Use dynamic navigation field: Activates an algorithm that makes the

simulation more realistic but significantly increases computation time

(default setting: Disabled). If dynamic flooding is enabled in the settings

of individual destinations, it is applied for them regardless of the general

setting.

• Automatically find floor connectors:
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– Floor connectors such as stairs, [escalators][Escalators], and eleva-

tors can be placed on a path to allow agents to use the respective

connection element.

– If an agent’s next destination is on a different floor without an explicitly

defined floor connector, the agent will automatically choose the

nearest connector.

– The object chosen is always the one that leads to the destination via

the shortest global path.

* Even stairs and escalators that are not floor connectors are au-

tomatically accessed by agents.

* In rare cases, the automatic selection of floor connectors may

lead to undesirable results.

Advanced Settings

System sttings

• Maximummemory [GB]: Defines the maximum usable RAM for the simu-

lation.

– By default, a maximum of 3/5 of the available memory or 100 GB is

used – whichever is smaller.

– The value should be specified as a multiple of 2x .

• Compress output: Saves simulation results in a zip archive to save storage

space. This is enabled by default.

Model settings

• Update rate of navigation field [Simulation Steps]: Specifies after how

many simulation steps the navigation field is updated. By default, updat-

ing occurs after each step.

• Distance between two evaluation positionVectors on OSM Circle [m]:

– Determines the distance between two positionVectors on the OSM

circle disk, which are evaluated as the next possible position for an

agent.

– This value should only be adjusted if agents get stuck in narrow

seating rows, for example, as reducing it increases computational

effort.
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– Default value: 0.15 m.

• Maximum queue angle deviation [°]:

– Defines the largest angle within which a queue can form around an

object (0–180°).

– Default value: 30°.

• Cancel simulation automatically:

– Ends the simulation automatically if unresolvable traffic jams occur.

– Default value: Disabled.

Once all settings are configured, click Apply to start the simulation. A progress

bar indicates the current status.

• Under Details…, additional information about the simulation progress can

be viewed.

• With Cancel, the simulation can be stopped at any time.

• After completion, the finished simulation results will open automatically.

Tip: While the simulation is running, you can open a second instance of crowd:it

to see the first results.

5.7.3 Run simple assessment

As an alternative to the full simulation, a simplified assessment can be per-

formed.

• No paths need to be created.

• Agents automatically choose the shortest route to the nearest destination.

• Only origins, destinations, and floor connectors need to be defined, but not

connected – agents will independently find the best path, even across

multiple floors.

5.7.4 Further Editing

After executing a simulation, simulation objects and paths can no longer be

edited.
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• Subsequent editing would lead to a discrepancy between the simulation

results and the original geometry.

• If changes are necessary, a warning will appear with the following options:

1. Delete results – Deletes all results and allows editing the file.

2. Copy project – Creates a new project file without simulation results.

3. Cancel – Cancels the process.

• Regardless, simulation results can be removed at any time under Simula-

tion > Delete results.

5.8 Visualize

In the Visualizemenu, you can customize the colors for both the simulation

results and the display of objects and geometry.

5.8.1 Agents

When selecting Agents…, a dialog appears that allows you to adjust the color

of agents and their movement paths. The reset button restores the default

values. Changes are only applied after clicking Apply.

Agent Color

Agents can be colored based on specific characteristics, including:

• Origin

• Destination

• Path

• Persona

• Navigation State: Colors the agents based on their current navigation

state, i.e. walking, waiting, on stairs, etc. This is particularly useful for

debugging and analyzing the behaviour of agents.

• Next Destination: Colors agents according to the next simulation object

they will reach.

• Congestion: Green if not in congestion, red if in congestion.

• Velocity: The faster the agent, the brighter its color.

• Social Distancing: Colors agents based on their proximity to others (ap-

pears only if Social Distancing is activated)

61



CHAPTER 5. MICROSCOPIC SIMULATION

• Group: Displays lines connecting each individual within the group.

• Group Size: Represents group size, not the group itself.

• Time of Exit: The earlier an agent leaves the simulation, the brighter its

color.

• Custom: Choose a custom color to color the agents.

A legend in the lower-left corner may appear to explain the color coding.

Agent Traces

To assist your analysis, movement paths of agents can be visualized in real-

time. Enable Draw agent traces to display them.

The following display options are available:

• Color: Choose whether movement path colors should match the agent’s

color or define a custom color for paths.

• Style: Select Fading to allowmovement paths to fadeover time. Otherwise,

the full path remains visible.

• For: Choose Active to draw movement paths only for agents still active in

the scenario. If you have selected specific agents via Identify Agents, the

option Selected will be enabled.

5.8.2 Display Evaluations

Under Visualize > Show Evaluations…, you can toggle evaluation objects on or

off.

5.8.3 Colors

You can adjust the color palette of your simulation under Visualize > SetColors….

This allows you to change the colors of simulation objects, simulation object

types, the background, walls, and evaluation objects. To change the color of
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individual elements, enter the element name in the provided field. Additionally,

all elements can be hidden similarly to CAD programs.

Attention! Hidden simulation objects are not displayed but still affect the

simulation.

You can also change the color of a simulation object by right-clicking on it

and selecting Set fill color…. To change the outline, you can select Set outline

color….

5.8.4 Object Labels

With Visualize > Object label…, a dialog window opens where you can enable

or disable labels. These labels apply to all object classes, from walls and

unassigned simulation objects to origins and stairs.

5.8.5 Set Start Time

Under Visualize > Set start time…, you can define a start time in the format

hh:mm:ss. This setting is reflected in both evaluations and the playback time-

line. This feature is especially useful for process simulations, such as simulating

a train station with a timetable.

Attention: If you set the start time, the times of the time-dependent Selection

processes must also be adjusted.

5.8.6 Playback Speed

With Visualize > Set playback speed…, you can accelerate or slow down the

simulation runtime.

5.9 Analyze

Once your simulation is complete, and any visualisation settings defined, you

can evaluate your results.

5.9.1 Agents

In crowd:it it is possible to analyze the behaviour of individuals and groups of

individuals. The following menu entries describe how.
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Identify Agents

In order to consider individual agents and their personal details, select the

Identify agents tool from the toolbar and click on any agent you wish to know

more about.

A table in the right panel displays the key data of the agent and a trace displays

the path so far. To identify multiple agents, drag a rectangle over the agents

you wish to highlight, or hold the Ctrl-Key and individually select additional

agents. De-selection is similarly available. When selecting multiple agents,

three buttons display underneath the agents’ key data: <-, Statistics and ->. To

navigate between each agent’s key data use the <- and -> buttons. To display

statistics about all selected agents, select Statistics.

Search Agents

If you are interested in a particular agent, and know its ID, use Search Agent…

to locate it and display its details and Path as in Identify Agents.

5.9.2 Evaluation objects

To evaluate areas of your scenario, crowd:it provides various evaluation ob-

jects, as described in the following menu entries.

Tripwire

After drawing, a dialog will appear with the following options:

• Name: The nameof the counting line, whichwill be displayed in the legend

and in the charts.

• Color: The color of the counting line. This is helpful for quickly identifying

the counting line in the plan.

• Count each agent only once: This option is selected by default. You can

deselect it if, for example, you want to count the total number of agents

in a process simulation, even if an agent has crossed this line multiple

times.

• Unidirectional: You can choose to count only agents moving in a specific

direction across the counting line, or you can count in both directions. If
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you select this option, you can adjust the direction in the lower window

by clicking Reverse orientation. An arrow will appear on the counting line

to indicate the direction in which agents will be counted.

Once the counting line is created, the following options are available via a

right-click:

• Properties…: This will open the dialog described above so you can modify

settings.

• Summary…: Opens an exportable table summarizing key positionVectors,

such as the number of agents that have crossed the counting line and

the times when the first and last agent crossed the line.

• Chart…: Here you can display a chart directly. The available charts are

described below.

– Number of agents: The number of individual agents that pass the

counting line and at what time.

– Speed: Provides statistics on the speed of agents when they cross

the counting line (minimum, mean, median, maximum).

– Evacuation time curve: Displays the number of agents crossing the

counting line over time.

– Weidmann (Speed/Flux): This chart plots the Weidmann curve as

well as the fundamental chart for speed and flow based on agents

crossing the counting line.

– Other custom charts can also be created. This is done via Analyze >

Create chart… and is described here.

• Export data as .csv: This allows you to export the raw data for further use

in .csv format.

• Copy to floor…: This allows you to copy the counting line to other floors. Af-

ter applying, new simulation objects will be created on the selected floors.

These objects will have the same properties as the original simulation

object.

• Edit geometry: Move the counting line using the blue circles at both ends.

Once youare satisfiedwith theposition of the counting line, click anywhere

outside the line to end the action.

• Delete: Deletes the counting line.
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Rectangle

With the Draw evaluation rectangle tool you can draw a rectangular box on

the plan. As with the Tripwire, you can assign a name and color.

A right-click will show a context menu, as described here.

In addition to the predefined charts available for counting lines, rectangles

have the following:

• Base charts:

– Local density: Standard density calculations (agents per square me-

ter) within the rectangle area.

– Local Voronoi density: Voronoi density calculations within the rect-

angle area. Caution: this value may be inaccurate if the evaluation

area is too small or lies over obstacles.

– Timespent inarea: Creates a data positionVector each time an agent

enters the rectangle and records the duration of each visit.

– Aggregated time spent in area: Provides a data positionVector per

agent and aggregates the time they spent inside the rectangle.

* Maximum individual congestion duration: This counts how long

each agent is in congestion within the area. The criteria for when

an agent is considered to be in congestion can be adjusted in

the Evaluations tab next to the floor plan view. A more detailed

description can be found [here][Congestion].

* Agents in congestion over time: Displays the number of agents in

congestion at a given time.

• Weidmann charts:

– Weidmann (Density/Flux)

– Weidmann (Density/Speed)

Additional custom charts can also be created. This is done via Analyze >Create

chart… and is described here.

Polygon

With the Draw evaluation polygon tool you can create a closed shape that

behaves similarly to the evaluation rectangles, but is not rectangular. When

creating your polygon, you can add as many vertices as needed. The Del key
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will remove the last added vertex. To close the polygon, click near the first

positionVector or press Enter.

A right-click will show a context menu, as described here. The same charts

are available as for the Rectangle. The creation of custom charts is described

here.

Warning: Polygonsmust be convex; otherwise, no evaluationswill be calculated.

(A convex polygon does not contain any inward-facing corners.)

5.9.3 Evaluation Settings

Some evaluations can be more precisely adjusted by the user. For example,

criteria for detecting congestion can be defined by the user. These settings

apply to all evaluations of this type. All globally valid settings can be set in

[Info Panel][Info Panel] area under the Evaluations tab. The tab is only visible if

simulation results are present.

Congestion Settings

The second section contains all settings related to congestion evaluation:

Max speed limit…

• … in the plane[m/s]: Describes themaximum speed below which a pedes-

trian is considered to be in congestion.

• …onstairs [m/s]:Describes themaximumspeedbelowwhich apedestrian

is considered to be in congestion when moving on stairs.

• … in relation to free flow speed [%]

• Min. time threshold [hh:mm:ss]:Describes the minimum time an agent

must stay below the speed limits before being considered to be in con-

gestion.

Note that an agent’s speed must fall below both the absolute and relative

thresholds to be considered in congestion.

Agents that have not yet moved (see also premovement time), i.e. whose pre-

movement time has not yet expired, are not taken into account in congestion

detection.
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Social Distancing Settings (only visible if social distancing is enabled)

Under Analyze->Social Distancing… settings for the evaluation of social dis-

tancing can be found:

Social distance [m]: Indicates the distance (center to center) at which an

agent is considered to be violating social distancing behavior.

Exposure time threshold for calculation [hh:mm:ss]: Indicates the number of

seconds that an agent must violate social distancing behavior before it is

considered a violation of the rule.

Exposure time threshold for visualisation [hh:mm:ss]: Sets the time threshold

after which the circles around the pedestrians turn red.

Exclude agents on same path: If you want to exclude agents who are on the

same path, you can check the option below. All agents assigned to the same

path will be ignored in the calculation of congestion.

5.10 Result Presentation

5.10.1 Charts

Use charts to quickly and clearly present the results of your simulation. You

can select a pre-defined chart (see Tripwire, Rectangle or Polygon) or create

a custom chart.

For each simulation object, pre-defined charts are available via a right-click

on the object. The appearing context menu offers Chart…. Here, some most

common charts are offered. If you want to create a custom chart, check here

for more information.

Creating a Chart

Use Analyze >Create chart… to create a custom chart. A dialog will then appear

to guide you through the process.

In the first step, you must decide whether to create a chart from a template

for a specific area type or a completely custom chart. If you choose a custom

chart, you will be directed to the customization dialog (see next chapter).

Under chart templates, you can select a template that matches your area

type and the area(s) to be analyzed.
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Chart Customization

In the customization dialog, various options are available to tailor your chart:

• Select chart type: Choose from scatter plot, bar chart, or line chart.

• Select data: Choose from the available data series.

• Refine data: Apply functions such as min, average, max, or median to

your data series.

• Design data: Customize the data series (color, name, icons, etc.).

• Design chart: Set the layout and title of the chart.

Clicking Calculate in the right-hand window shows how your selection affects

the result. This allows you to see immediately whether the chart meets your

expectations. It is recommended to use the Calculate button frequently, as

there is no reset button. Frequent calculations make it easier to manually

revert changes if needed.

You can switch between different configuration levels by clicking the desired

field on the left side of the window. To finalize and display the chart, click the

checkmark button.

Select chart Type

In the first configuration field, choose the type of chart you want to create.

Available options:

• Line, Scatter, and Mixed: Best for displaying numerical data series. You

can choose between line, positionVector, and mixed charts. Line charts

connect all data positionVectors with a line, while positionVector charts

display each data positionVector as an individual small circle. The mixed

option allows combining line and positionVector data series.

• Area: Best for representing numerical data series. Choose between stan-

dard and stacked area charts. If stacked is selected, it is recommended to

color the areas under the individual data series to avoidmisinterpretation.

• Bar: Best for data series thatmap categories to numerical values. Choose

between standard and stacked bar charts.
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Select data

This is the most complex panel, where you select the data series. A description

of available data series can be found in the Data Series section.

To quickly find the desired data series, filter by evaluation area type (floor,

source, elevator, etc.) or x- and y-axis dimensions.

The panel is structured as follows: on the left are all possible data series, while

on the right are the data series already added to the chart. A more detailed

description of individual data series and their use cases can be found in the

“Data Series” section.

To add a data series to the chart, select it in the left section and either double-

click it or press the button .

Note: Only data with matching area and series types can be displayed in the

same graph. Once a data type is selected on the right side, only compatible

options remain on the left. For example, if the selected x-dimension is “Time,”

you cannot select data where the x-dimension is “Density.”

Refine data

In the next step, you can apply functions to the data series, such as summing

values over a specific window, calculating the average, or displayingminimum

and maximum values.

There are two ways to set aggregation time intervals: Simple and Advanced.

• The Simple option allows users to define the aggregation window and

interval size.

• The Advanced option lets users set the start and end positions of each

interval.

Design data

This section allows you to define visualization settings for individual data series,

including labeling, coloring, and representation. Options vary depending on

the selected chart type.

Design chart

In the final section, general visual aspects of the chart are set, such as the title,

axis labels, and chart size.
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Calculating and Displaying the Chart

To finalize and generate the chart, simply press the Checkmark Button ( ) at

the bottom.

The final chart will then be displayed. If crowd:it has to process a large amount

of data, the display may take some time. Don’t worry—the results will appear

shortly!

Once generated, the chart can be exported using various methods:

• : Copy to Clipboard

• : Save as File

Available export options:

• .png: Saves the chart as an image.

• “.csv - raw data”: Saves the base data without aggregation.

• “.csv - calculated data”: Exports the result data series after applying the

aggregation function.

Alternatively, you can save the configuration using the Star Icon (see [Re-

ports][Berichterstattung]).

Data Series

Number of Agents

Number of agents over time: This represents the number of people in a specific

geometry (scenario, floor, rectangle, polygon, or tripwire) over time. Using the

average and max functions (see Refine data), the average and maximum

number of people over time (interval in seconds) can be determined.

Walking times

Travel times can be determined by creating tripwire at the starting position-

Vector (A) and endpoint (E). A tripwire chart shows howmany people cross

each tripwire at a given time. To determine how long people take to travel from

A to B, a counting line can be created at both A and B, and a counting line tour

table can be generated. Additionally, the times of the last agent movement

per floor can be displayed via floor evacuation times.
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Speed

Speed over time: This represents the speed of agents in a specific geometry

(floor, rectangle, polygon) over time.

Dwell Time and Congestion Analysis

• Time spent in area: The duration an agent remains in a specific area (floor,

rectangle, polygon).

• Aggregated time spent in area: The total accumulated time an agent

spends in a specific area (floor, rectangle, polygon).

• Max individual congestion durations: The longest single time period an

agent moves at a speed below the congestion threshold speed.

• Total congestion duration: The sum of time periods in which an agent

moves below the congestion threshold speed.

• Agents in congestion over time: The number of agents experiencing con-

gestion at a specific time.

Density

• Local density over time: Number of people per square meter over time.

• Local voronoi density over time: The available space per person over time.

Density heatmaps illustrate where bottlenecks occur.

Fundamental Diagrams

Fundamental diagrams based on Weidmann can be displayed for simulation

output comparison:

• Flux over Density: Represents people flow compared to density.

• Density vs. Speed: Represents average density compared to pedestrian

speed.

• Flux over Speed: Represents people flow compared to speed.

Social Distancing

Only available if results include Social Distancing

• Number of Agents by Maximum Exposure Duration: The number of people

compared to their maximum contact time when violating the minimum
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distance with another person. A distance violation occurs when a person

stays below the adjustable minimum distance to another person for

longer than the configurable minimum exposure duration.

• Number of Agents by Total Exposure Duration: The number of people

relative to their aggregated duration of distance violations with others.

• Agents Who Violated Distance: The number of people over time who

violated the required distance from another person.

• Agents Who Stood Too Close Over Time: The number of people over time

who failed to maintain the required minimum distance.

• Duration of Violations: The maximum duration of individual distance vio-

lations over time.

Elevator

The following data series are available for elevators:

• Agents in the elevator: Displays the agents currently in the elevator.

• Number of waiting agents per floor: Displays the number of waiting people

per floor over time.

Queue

The following data series are available for queues:

• Agents in queue: Shows the queue length over time. It can be used to

determine when the queue is longest during the simulation.

• Length per stay in queue: Similar to dwell time, this data series represents

the waiting time relative to the arrival time.

5.10.2 Summary Tables

The menu option Analyze > Create Summary… opens a dialog where you can

choose between multiple automatically generated tables. All options are

categorized and explained below.

Area Summary

Provides a summary for each evaluation rectangle and polygon (area). Each

area is described by:

73



CHAPTER 5. MICROSCOPIC SIMULATION

• The average number of people in the area.

• The maximum number of people in the area at the same time.

• The minimum, average, and maximum time spent in the area by all

agents.

• The number of different people who have been in the area.

• The number of arrivals in the area.

Tripwire Summary

Provides a summary for a counting line, including:

• The total number of counted agents.

• The time when the first agent was counted.

• The time when the last agent was counted.

Path Summary

Each path is described in detail:

• The number of people assigned to the path.

• The minimum, maximum, and average time in seconds to traverse the

path.

As with Tripwire Summary, use Edit to define the evaluation period.

Origin-Destination Summary

Provides a detailed overview of each origin-destination combination:

• The number of people moving from the respective origin to the corre-

sponding destination.

• The minimum, maximum, and average time in seconds to complete the

journey.

As with Tripwire Summary, use Edit to specify evaluation settings (e.g., including

lead time in travel time).
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Elevator Summary

This table provides a detailed report on each elevator.

The following information is displayed:

• Total number of agents who used the elevator during the simulation.

• Average and maximum waiting time for the elevator (measured from

arrival at the elevator to when the pedestrian starts entering the elevator.

Important: all other pedestrians must exit the elevator first).

• Average andmaximum time to enter the elevator (measured from when

the pedestrian starts entering until the pedestrian’s torso is inside the

elevator).

• Average andmaximum ride time in the elevator (measured fromwhen the

pedestrian’s torso is inside the elevator until the pedestrian starts exiting,

including stops at other floors).

• Average andmaximum time to exit the elevator (measured from when

the pedestrian starts exiting until their torso has fully left the elevator

geometry).

Elevator Stop Summary

This table indicates how often each elevator stops at a specific floor.

Important: If an elevator does not open its doors at a floor, the floor is not

counted, even if the elevator passes through it.

5.10.3 Critical area detection

An automatic calculation of all critical areas can be triggered with Analyze >

Critical area detection….

The following settings can be made:

• Congestion threshold value [hh:mm:ss]: Defines the minimum duration

that an agent must spend in congestion in an area for this area to be

classified as critical.

• Use bounding box: If this option is activated, a rectangle is automatically

drawn around all critical areas. Otherwise, a polygon is drawn around

the critical areas for each critical area.
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The same calculation is started in the background that is also used for theMax

congestion duration heatmap. The area is divided into one meter cells and in

each cell the maximum time is measured, during which an agent has been

stuck already. If this time exceeds the set congestion threshold value, the cell

is classified as critical. All cells are iterated over and grouped into clusters. An

evaluation object is created for each cluster and displayed in the floorplan.

The settings for when an agent is considered to be in a congestion can be

made here.

The critical area detection can be used in a congestion analysis to identify the

congestion areas and to analyze these locations in more detail.

5.10.4 Heatmaps

Heatmaps allow for the interpretation of simulation results by dividing the

scenario area into square tiles. These tiles are then coloredbasedona selected

criterion, helping identify congestion areas that can be further analyzed using

evaluation objects.

The Heatmap dialog can be opened via the Analyze > Heatmap…menu.

The menu is divided into three sections:

• Measurement: Here, you select the coloring criterion, the time period to

analyze, and the tile size. Click Advanced Setting** to unlock all available

options.

– Criterion: Defines the coloring criteria (options are detailed in the

Coloring Criteria section).

– Start time and End time: Specify the time in seconds over which you

want to calculate the heatmap values.

– Moving average: Define the time span for averaging values. Example:

If you choose 10 seconds, the next 10 time steps will be considered

and averaged.

– Tile size: Sets the size of measurement tiles in meters.

– Consideragentswhile inpre-movement: Enable this to excludeagents

who have not yet started moving (see the Reaction Time section).

• Coloring: Displays a preview of the heatmap legend. Click the button next

to the preview to adjust colors.

• Floors: Define which floors the heatmap should be calculated for.
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Click OK to generate and display the heatmap.

To close the heatmap, select Delete from the menu above. To modify the

heatmap, select Heatmap… again.

Coloring Criteria

The heatmap tiles can be colored based on different aspects. The following

options are available:

• Mean length of stay: The average time agents spent within the tile is

calculated per tile.

• Time within social distance to any other agent (Max per Tile) - only avail-

able if simulated with Social Distancing: The time agents did not maintain

social distancing is calculated per tile. The settings are defined under

Personas and Social Distancing. The average is calculated from all times

and all pedestrians.

• Time within social distance to same agent (Max per Tile) - only available if

simulated with Social Distancing

• Agents: Indicates how many agents entered a tile over the observed

period. This can help determine path utilization.

• Evacuation time: Determines the last time an agent was present in each

tile. This helps identify which areas were completely evacuated at which

time.

• Max congestion duration: Counts the seconds in which an agent was

in a congestion (even before entering the tile) until he leaves the tile.

The tile value is calculated as the maximum over all agents who were in

congestion. This heatmap is used for the critical area detection as well.

The congestion settings can be adjusted here.

• Density: Records the density of each tile across all time steps. This means

the number of agents in each tile at a given moment is averaged. (Mean

or maximum density can be used as comparison criteria between tiles).

Density heatmaps can be colored according to Fruin’s defined service

levels.
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• Speed: During the simulation, the speeds of all agents entering a tile

are averaged. (Minimum, mean, or maximum speeds can be used as

comparison criteria between tiles).

Color Settings

Depending on the use case and audience of the heatmaps, it may be nec-

essary to adjust the color assignment. With a click on the , a color settings

dialog opens with the following settings:

• Scheme:

– Default: The default color scheme is white, blue, and black.

– Custom: A user-defined color scheme. If you change any of the

following settings, the color scheme becomes custom.

– Service Level: These color schemes can be used for heatmaps with

high density:

* Sidewalk: Service levels for sidewalks.

* Staircase: Service levels for using stairs.

* Queue: Service levels for queues.

• Gradient: Specifies whether color changes are continuous or discrete.

• Color Values: Here, you can define the color values. First, specify whether

the color values should be relative ( where the maximum value is set

in the dialog) or absolute (where the maximum value is determined by

the highest achieved value). Next, set the values. Values can be added,

removed, or edited.

• Legend Preview: This section displays a preview of the heatmap legend.

5.11 Export

After visualizing and analyzing your simulation, youmay want to export a video

or screenshot of the results. These videos or screenshots can be used to get an

overview of the results, highlight specific time steps or critical positionVectors,

or create outputs such as heatmap displays and agent movement paths.

5.11.1 Screenshot

The menu item Analyze > Export Screenshot… allows you to create screenshots

of multiple (or all) floors at the current time or at different intervals.
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In thewindow that opens, you first need to specify the filename under which the

screenshots should be saved. Then you can select which floors and settings

you want to “photograph.” Additionally, you must choose the time at which

the screenshots should be taken.

Click the Advanced Settings button to unlock a range of additional options.

With the ImageSize settings, you candefine the desired resolution of the screen-

shot. The width and height are bound to the aspect ratio of your floor. Alterna-

tively, you can set the resolution by specifying howmany pixels in the resulting

image should represent one meter in your floor. If you change the Pixels per

Meter value, the width and height will automatically adjust accordingly—and

vice versa.

To get an impression of your current settings, you will find a live preview on the

right. If you have selected a heatmap in the Advanced Settings section, you

can click the Recalculate Heatmap with Current Settings button to generate a

preview of the heatmap.

Once configured, you can save this report as a template (by clicking ) and

reopen it later (see section Report Generation) or directly export it by selecting

a folder and then clicking Apply**.

5.11.2 Video

With Analyze > Export Video…, you can create videos of the simulation.

Here, you can specify the filename for your video(s), select which floors should

be displayed, choose the video’s time span, configure visualization settings,

and set the desired resolution—similar to the screenshot dialog. Additionally,

there is the Follow Marked Agent option. This option is only available if you are

tracking a single agent in the visualization window (see Select Agents). If this

option is enabled, the video will follow this agent across floors. For example, if

the tracked agent is on Floor 1 for the first thirty seconds of your simulation and

then moves to Floor 2, the video will display Floor 1 for the first thirty seconds

and then switch to Floor 2.

Save your configuration as usual with the star icon ( ) (see also here) or

generate the videos directly by clicking Apply. A target folder can be set via

Folder . crowd:it will be locked during the export process.

After the export, you can open and play the finished videos in a media player.
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5.11.3 Reporting

Often, you will need to simulate multiple scenarios of the same situation, out-

putting the same reports. In order to save time, crowd:it allows you to save

your screenshot, video and chart settings. This feature is named Reporting.

Reports can be viewed, re-opened, and re-exported across multiple scenarios.

Save report

The star button can be found in all dialogues in which the Reporting function

is available. This button allows you to save the current setting as a report.

In order for a report to be recognised, a corresponding name must be entered

by the user. The report is then added to the saved reports.

Saved Reports

All saved reports can be viewed, re-opened, re-exported and deleted under

Analyze > Saved reports….

You can select a single or multiple reports to export or view by using the

checkboxes. A double click will open the relevant dialogue menu for that

report.

The list of reports can be filtered using the search bar on top of the dialog.

A pop-up menu can be opened by right-clicking in the table so that existing

reports can be renamed or duplicated.

Furthermore, created reports can now be saved or imported as JSON. In this

way, saved reports from one project can be integrated into another. Above all,

this can be applied to reports using evaluation polygons/rectangles, too. It is

important for this that all designations for evaluation polygons and floors are

the same from project to project. Excluded from this feature are video reports

following an agent.

See advanced tools for more information.

5.12 Quick Edit

With Quick Edit…, you can select and edit multiple objects simultaneously in an

additional window.

The selection process works by applying various filters to your objects. The first

filter is the object type:
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• Assigned simulation objects (e.g., source, destination, etc.)

• Unassigned simulation objects

• Walls

• Sets (groups of simulation objects)

• Subpaths

• Paths

• Evaluations

Sets, subpaths, and paths can be renamed or deleted. Evaluations can also

be deleted. Additionally, simulation objects, subpaths, and sets can be added

to a set.

For unassigned simulation objects, you can use the Assign Type option to

convert the selected objects into, for example, sources. The same dialogmenu

as in [Assign Simulation Objects][Simulation Objects] will appear.

For simulation objects with an assigned type, the following actions are avail-

able:

• Reset

• Create Evaluations: Generates evaluation polygons that precisely match

the geometry of the selected simulation object.

• Show

• Hide

• Add to Set

• Rename

• Delete

• Select

5.13 Advanced Tools

5.13.1 Automatic Report Generation via Console

Installed JARs

After installation, the JAR files are located in the following directory onWindows:

AppData > Roaming > accu-rate > crowd-it > bin

They are divided into the subdirectories gui and kernel.
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Workflow

The process is as follows:

1. Open the project in crowd-it

2. Create saved reports

3. Under Analyze > Saved Reports…, select the desired reports

4. Right-click > Export as JSON…, select a folder, and save the JSON file

5. Open the console

The following graphic provides an overview of the process:

If the GUI JAR is accessed directly via the console, the automatic report gener-

ation feature can be used.

“‘bash java -jar –filename= –jsonFile= –exportReports

5.14 Troubleshooting

5.14.1 Slow simulation calculation: Performance tips and tricks

Sometimes the calculation of simulations seems much slower than usual, but

there are usually simple explanations for this.

To get your results faster, you can check / adjust the following things.
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Check geometry

For simulation, each additional line in your CAD tool affects the simulation time.

This also applies to lines that are located in areas that cannot be accessed

(e.g. drawing cables in walls).

Reduce lines within the simulation

Usually, the fastest way to speed up simulations is to move all objects that are

not needed / located in inaccessible areas to hidden layers in the CAD tool.

This way they remain in the CAD tool but do not influence the simulation time

anymore. With our Simplify Geometry tool, you can also remove all objects

that are not needed for the simulation.

Check line duplication

Oftenduplicated lines are found inCADplans, which lie on topof eachother and

thus offer no further added value. Tip: Most CAD tools offer simple commands

to remove such objects.

Check coordinate system origin

Within crowd:it the same coordinates are used as in the CAD plan. This means

that a polyline in your CAD tool has exactly the same coordinates as in crowd:it.

This simplifies the search for certain objects in the CAD program, but also has

a decisive disadvantage. If the coordinates in your CAD program are very

large, this also means large coordinates in crowd:it. Since the simulation file

contains much more information than the CAD file (agent positions), large

coordinates can result in a significantly higher memory requirement for your

simulation file. In addition, very large coordinates can also lead to rounding

errors in the simulation calculation.

Therefore, we recommend moving the geometry in the CAD tool to the coordi-

nate system origin.

Check simulation settings

This section should be viewed with caution, as an incorrect setting of the

simulation settings can have a strong influence on the simulation results.
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Nevertheless, it should be mentioned, as a lot of performance can be gained

here.

Draw boundary lines

To avoid long calculation times, you can draw boundary lines around the

simulation area. To do this, use the Walls tool. Make sure that all simulation

objects lie completely within the boundary lines and draw the boundary lines

as open walls.

Floor discretization

Especially in large viewing areas, it is usually not necessary to use very fine

granular navigation because there are no narrow paths such as between

stage seats.

In these scenarios, the discretization of a floor can be increased from the

default value of 0.1 meter to 0.5 meter. This setting is called cell discretization

and can be changed [here][Show and edit properties].

This can speed up the calculation of the navigation extremely but might lead

to stuck agents in very narrow areas.

5.14.2 Out of memory error

Especially with larger simulations sometimes the error “Out of Memory” can

occur.

Reasons for this can be endless, but the most common reason is that the

calculation doesn’t get enough memory assigned.

If you experienceanout ofmemory error, please contact us (product-support@accu-

rate.de) and we will look for a solution together.
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Macroscopic Calculations

crowd:it offers several calculation modes. In addition to a microscopic simula-

tion, macroscopic calculations can also be performed.

Currently, the following macroscopic calculations are possible:

• Predtetschenski & Milinski (P&M): The Predtetschenski & Milinski method

can be used to quickly and approximately determine evacuation times

and bottlenecks. It primarily works with pedestrian flows. For a detailed

explanation of the P&Mmethod, please refer to the relevant literature.

6.1 Workflow

To perform a macroscopic calculation, the following steps are required:

Optional:

1. Import geometry, e.g., as a background image, as a template for modeling

2. Scale the background image to the correct size

Mandatory:

3. Define way elements

4. Connect way elements

5. View and export results

Unlike microscopic simulation, macroscopic calculation does not require an

exact geometry. To determine the necessary data, wayelements are drawn

and corresponding parameters are assigned. To facilitate the process, it is
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recommended to import an existing floor plan, including dimensions, as a

background image (see also here) and scale it to the correct size. A quick

tutorial can be found here. This allows required way lengths and widths to be

conveniently measured from the plan.

6.2 Quick Introduction

A quick introduction can be found here.

6.3 DefineWay Elements

To build a scenario, the first step is to define way elements. The following

options are available in the toolbar:

• : Defines a start element. Every scenario must include at least one way

element of this type.

• : Models a corridor.

• : Models a stair up.

• : Models a stair down.

• : Models a bottleneck.

6.3.1 Create start element

After clicking the icon , a drawing tool opens, allowing you to define a rectan-

gular element within the drawing space.

In the Predtetschenski & Milinski model, the start element determines the initial

density, which then flows through way elements as a pedestrian flow. To

calculate the initial density, several parameters must be set.

These parameters are entered in the dialog that appears after defining the

area:

General Information

• Name: A meaningful name is useful since it will be reused as an identifier

in the results.

• Description: Space for additional information, notes, or comments about

the object.
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Geometric Properties

• MinimumWidth: The narrowest part of the start element.

• MaximumWalking Distance: The longest walking distance within the start

element (in meters), usually the diagonal of the rectangle. This can be

measured directly from the drawing area (by clicking the icon ) or taken

from other documents.

The personas, i.e. the different person types that appear in the model, can

be defined in the persona table. This results in the initial density, which is

calculated from the sum of the total projection area of all person types divided

by the available area. The resulting density is is listed in the Overview.

Note: The walking distance and minimum width are required to calculate the

walking time within the start element. An additional corridor element is not

necessary.

Density Calculation

• Number of Pedestrians: The total number of people in the start element.

At least one person is required for the process to work.

• Available Area: The area of the start element in square meters. It is

automatically calculated from the drawn rectangle but can be adjusted

manually.

Once all parameters are set, the start element is created by clicking Apply.

6.3.2 Create Corridor

A corridor represents a path on a flat surface. The model calculates the ca-

pacity of the way element and the time required for pedestrian flow based on

maximum walking distance and minimum width.

After selecting the icon , a drawing tool opens, allowing you to draw the

corridor. A dialog then appears to define its properties.

By default, the horizontal path is suggested as a rectangle. If an arbitrary

polygon is desired instead, there are two options:

• First, create a simulation object as a polygon ( ), then select the object

by double-clicking on it and assign Corridor.
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• After drawing the rectangle, adjust the geometry with a middle mouse

click on the element (see also here).

As with the start element, a name and description can be assigned (see

General Information).

Required Properties

• MinimumWidth: The narrowest part of the path.

• MaximumWalking Distance: The longest walking distance within the ele-

ment.

Both values are entered in meters and can be either manually input or mea-

sured using the measurement tool in the drawing area. Simply click the icon

next to the input field, which opens the drawing area for measuring the desired

distance.

6.3.3 Create Stair up or down

Pedestrian flow slows down on staircases. The model accounts for this delay

based on the width and direction (upward/downward) of the staircase.

After selecting the icon for an upward staircase or for a downward stair-

case, the staircase is drawn. A dialog then opens for entering the required

values.

Similar to the corridor element, the minimum width and maximum walking

distance must also be set ( see here).

6.3.4 Create Bottleneck

Doors and other bottlenecks must be modeled separately, as pedestrian flow

is reduced in these areas. The clear passage width determines the impact on

pedestrian flow.

After selecting the icon , a line is drawn in the drawing area. A dialog then

opens to define the basic properties ( see General Information) and the pas-

sage width.
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6.4 Connect way elements

For calculations, the way elements must be connected. This is done using the

icon in the toolbar.

After switching to path mode, clicking on a way element creates an arrow that

can be connected to another way element (except for the start element). The

arrows can be deleted either by right-click via the context menu or by pressing

the DELETE-key.

Important: At least one path must originate from a start element, otherwise,

no calculation is possible.

As long as an outgoing path exists from an element, that element is not con-

sidered an exit. In other words, if a path element should act as an endpoint for

analysis (see overview table), ensure that no outgoing arrows exist from that

element.

6.4.1 Merging

When two paths merge, the pedestrian flows in the model are added together.

Time delays due to staggered arrivals are not considered, which may slightly

overestimate evacuation times. If this effect should be explicitly modeled and

it is ensured that pedestrian flows arrive with staggered timing, two separate

paths can be modeled, and the way element can be duplicated.

This ensures that the element is available at full capacity for each incoming

pedestrian flow.

Caution: Simply reducing capacity by assigning smaller widths to duplicated

elements does not work, as the correct densities would not be accounted for.

6.4.2 Splitting

If a way element leads tomultiple destinations, pedestrian flows are distributed

based on the width of the outgoing paths. If a different distribution is required,

the source can be divided into multiple sub-areas. The available area must

be adjusted accordingly.

The following image illustrates an example where pedestrian flows are dis-

tributed equally rather than according to adjacent escape path width:
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6.5 Overview of all modeled way elements

In the information panel to the right of the floor plan view, the Properties tab

provides an overview of all modeled way elements, including all properties

used as input for calculations.

Clicking a column title sorts the respective table column, which is useful for

sorting way elements by floors, for example.

Clicking a table row or hovering over a row highlights the corresponding el-

ement in the floor plan. Conversely, selecting an element in the floor plan

highlights the corresponding table row.

This overview can be exported for documentation purposes as a .csv or .png

file or copied to the clipboard for further use. (For detailed export instructions,

see here.)

6.6 Persona table

In the persona table, predefined person types based on Predtetschenski &

Milinski can be selected and weighted by percentage. The total must sum to

100%. The following person types are available according to the model:
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6.7 Modeling Tips

• Since this is a macroscopic model, an accuracy of 10–20 cm is sufficient.

Higher accuracy suggests a precision that the model cannot provide.

• Path elements should not be modeled in excessive detail. If necessary,

consider microscopic simulation. For example, a staircase with multiple

landings can be modeled as a single staircase.

6.8 Visualization Options in Macroscopic Mode

The mode-dependent menu bar contains the entry Visualize. Here, the follow-

ing visualization settings can be made:

• Show Paths: Paths can be toggled on and off.

• Set colors…: Macroscopic elements, walls, and the background can be

recolored, enabled, and disabled. Here is explained, how this works.

• Object label…: The configured information and the name of each macro-

scopic element can be displayed in the floor plan view. This is done via the

Object labels dialog. Under Showadditional info, the configured properties

are displayed in the path element.
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6.9 Calculation

The calculation of the model takes place in the Calculation tab, located to the

right of the Floor plan. Here, you can start the calculation and view the results.

In the upper area of the tab, the calculation type is specified. The model

according to Predtetschenski & Milinski (P&M) offers three different calculation

types:

• Comfortable conditions

• Dangerous conditions

• Normal conditions

For evacuation calculations, the calculation type Dangerous conditions is gen-

erally used. However, this can be individually adjusted by the user.

After selecting the calculation type, the results in the tables below are immedi-

ately updated.

6.10 Results

6.10.1 Overview Table

This table lists the following information for each exit or each path endpoint:

• Exit: Name of the exit, as defined in the name field of the way element.

• First Person walking time: Time in minutes when the first person reached

the exit.

• Last Person walking time: Time in minutes when the last person reached

the exit, i.e., when all individuals had left the scenario (e.g., a building).

This also includes congestion time.

• Maximum persons in congestion: Maximum number of persons who were

in a congestion in a way element on the way to the exit. Note: This number

is determined from the congestion analysis according to P&M by multi-

plying the congestion length with the maximum density defined in P&M.

This may lead to an overestimation of persons in the congestion, as the

maximum congestion density is 0.92 m²/m².

• Maximum congestion walking time: The congestion time is determined

across all way elements of a path. The maximum congestion time refers

to the path with the longest congestion time.

• Number of Paths: Number of paths leading to this exit.
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6.10.2 Detailed Analysis

In the lower area of the tab, a detailed analysis of the individual paths leading

to an exit is displayed. To view these, select the corresponding row of the exit

in the overview table. The detailed analysis contains the following information:

• Way element: Section or element of the path. The name was set in the

respective way elements and can be changed there.

• Min. width [m]: Minimum width of the way element in meters, as defined

here.

• Max. walking distance [m]: Maximum distance covered within this way

element. This value is specified by the user and can be changed under

here.

• First Person walking time: Time in minutes when the first person reached

the end of this way element.

• Cumulatedwalking time: Total time required for the first person to traverse

the path including this way element.

• Congestion delay: Indicates whether and how long delays occurred within

this way element.

• Time for last person: Time when the last person left this way element.

• Number of pedestrians: Total number of people who moved through this

way element.

• Persons in congestion: Number of people who were in a congestion within

this way element.

To switch between the respective paths, you can use the arrow keys above

the table: and .

6.10.3 Exporting Results

The tables can be exported in various formats to be included in the results

report.

Below each table, there is an option to select the export format (.png, .csv).

After selection, the data can either be copied to the clipboard ( ) or saved as

a file ( ).

Note: When exporting as .png, only the currently visible table is exported. If the

table headers should be fully readable, the table must be resized accordingly.
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6.10.4 Calculation Parameters

To trace individual calculation steps and verify the calculation parameters

used, all relevant values are summarized in the Parameters tab. The listed

calculation parameters originate from the model and are derived from so-

called calculation value tables, which represent a fundamental diagram in

tabular form. Each density is assigned a speed and a pedestrian flow rate.

Note: In the original model, these values are listed in steps of 0.01. In crowd:it,

the original formula is implemented, allowing an exact value to be calculated

for each density. Therefore, slight deviations may occur compared to the table

values.

The following parameters are listed:

• Name: Name of the way element

• Type: Type of the way element

• q_in: Adjacent pedestrian flow of the way element in [m/min]

• q_max: Maximum capacity of the way element in [m/min]

• q_adjusted: If the adjacent pedestrian flow exceeds the capacity of the

way element, the pedestrian flow is adjusted. For this, the value from the

calculation value table for the maximum possible density is used.

• Congestion: Indicates whether a congestion formed at this way element.

If q_adjacent > q_max, a congestion occurs.

• Speed: Flow speed in [m/min] at which the adjacent pedestrian flow

moves through this way element. This value is derived from the calcula-

tion value table.

• Density: Density in [m²/m²] generated in the pedestrian flow.

• Q: Movement intensity in the way element, calculated as q_adjusted x

minimumwidth of the way element.

6.11 Analysis

In the Analysis tab, you can visualize and analyze the results of the calculation

in the floor plan.

Different colorizations of the respective path elements can be selected:

• Speed: Each path element is colored according to the speed of the pedes-

trian flow, allowing a quick overview of where the pedestrian flow slows

down.
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• Congestion delay: The delay time per path element indicates where de-

lays occur and where congestion forms.

• Time for last person: This option allows further selection of the target for

which the analysis should be performed. After selecting the target, each

path element is colored according towhen the last personmoving toward

the target passed that element. If multiple paths lead to the target via a

path element, the maximum value is displayed.

6.12 Export

The colored objects can be exported and saved as .png via the Export button.

A dialog opens, similar to the Export Screenshot** dialog in microscopic mode.

The following settings are available:

• Floors: Specifies which floors should be exported as a screenshot.

• Visualization: Allows enabling/disabling the legend and/or scale as well

as the floor name. Additionally, the floor boundary can be displayed when

a specific perspective is selected.

• Rendering: Determines the size of the exported image. The preview win-

dow on the right shows how the image will look. Additionally, you can

choose whether the floor should be displayed and saved in an isometric

perspective.

• File Settings: Specifies where the screenshot should be saved.
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Glossary

Deviation: Standard deviation

Agent: Simulated pedestrian

Disable dynamic navigation calculation: Disables dynamic flooding for this

destination.

Directed scaled area: A scaled area that can specify different directions to

define different braking/acceleration factors.

Heatmap: A spatial map with color coding based on density, speed, or other

aspects of the simulation.

Capacity: Capacity limitation. For example, how many agents can enter the

waiting area simultaneously.

Paths: Movement paths of a pedestrian.

Name: Name of the simulation object.

Path: The connection between the source and the destination along which

agents are supposed to move. May include intermediate destinations such as

stairs, portals, and waiting areas.

Portal: Interface connecting two floors.

Origin: Sources where agents are generated.

Queue: Element representing the start of a queue.

Reaction time: The response time to a specific event (e.g., alarm system), which

pedestrians “wait for” before they start moving.

Set: Group of simulation objects (sources, destinations, stairs, etc.).

Scaled area: Areas where agents can be slowed down or sped up.

Simulation object: Simple polygons in the CAD program that can later be

converted into sources, destinations, stairs, etc., in crowd:it.
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Floor: A collection of all geometries of a simulation observation area that are

on the same level.

Stair: Object representing a rectangular staircase.

Waiting zone: An area where pedestrians wait for a certain period.

Exit time: Themomentwhen an agent reaches the safe area or final destination.

Destination: Target areas that accept agents; sinks where agents are removed

from the simulation.
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